<!DOCTYPE html>
<html lang="en-US">
<head>

<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=no">
<meta property="fb:app_id" content="58923144965" />
<meta property="fb:pages" content="71411645007" />
<meta name="author" content="Evan Federowicz" />
<link rel="shortcut icon" type='image/x-icon' href="https://wccftech.com/favicon.ico" />
<link rel="apple-touch-icon" sizes="180x180" href="https://wccftech.com/icons/apple-touch-icon.png">
<link rel="icon" type="image/png" href="https://wccftech.com/icons/favicon-32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="https://wccftech.com/icons/favicon-16x16.png" sizes="16x16">
<link rel="manifest" href="https://wccftech.com/icons/manifest.json">
<link rel="mask-icon" href="https://wccftech.com/icons/safari-pinned-tab.svg" color="#5bbad5">
<meta name="apple-mobile-web-app-title" content="Wccftech">
<meta name="application-name" content="Wccftech">
<meta name="theme-color" content="#ffffff">

<style>@import url('https://fonts.googleapis.com/css?family=Fira+Sans:400,500|Open+Sans:400,700');</style>



	<!-- This site is optimized with the Yoast SEO Premium plugin v15.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>XPG Announces the SPECTRIX S20G PCIe Gen3x4 M.2 2280 SSD</title>
	<meta name="description" content="The XPG SPECTRIX S20G PCIe SSD features a read speed of up to 2,500 MB/s and a large amount of customizable RGB lighting." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://wccftech.com/xpg-announces-the-spectrix-s20g-pcie-gen3x4-m-2-2280-ssd/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="XPG Announces the SPECTRIX S20G PCIe Gen3x4 M.2 2280 SSD" />
	<meta property="og:description" content="The XPG SPECTRIX S20G PCIe SSD features a read speed of up to 2,500 MB/s and a large amount of customizable RGB lighting." />
	<meta property="og:url" content="https://wccftech.com/xpg-announces-the-spectrix-s20g-pcie-gen3x4-m-2-2280-ssd/" />
	<meta property="og:site_name" content="Wccftech" />
	<meta property="article:publisher" content="https://www.facebook.com/wccftech" />
	<meta property="article:published_time" content="2020-12-22T19:39:00+00:00" />
	<meta property="article:modified_time" content="2020-12-22T19:48:25+00:00" />
	<meta property="og:image" content="https://cdn.wccftech.com/wp-content/uploads/2020/12/hREM0v7n9sbjKmNx.jpg" />
	<meta property="og:image:width" content="960" />
	<meta property="og:image:height" content="960" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@wccftech" />
	<meta name="twitter:site" content="@wccftech" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Evan Federowicz">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="1 minute">
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Wccftech &raquo; Feed" href="https://wccftech.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Wccftech &raquo; Comments Feed" href="https://wccftech.com/comments/feed/" />
<link rel='stylesheet' id='wccf-main-css'  href='https://cdn.wccftech.com/wp-content/themes/wccf2016/style.css?ver=1608003897' type='text/css' media='all' />
<link rel='stylesheet' id='wccf-style-single-css'  href='https://cdn.wccftech.com/wp-content/themes/wccf2016/style-single.css?ver=1608003897' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://wccftech.com/wp-json/" /><link rel="alternate" type="application/json" href="https://wccftech.com/wp-json/wp/v2/posts/1233985" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://wccftech.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cdn.wccftech.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='https://wccftech.com/?p=1233985' />
<link rel="alternate" type="application/json+oembed" href="https://wccftech.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwccftech.com%2Fxpg-announces-the-spectrix-s20g-pcie-gen3x4-m-2-2280-ssd%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://wccftech.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwccftech.com%2Fxpg-announces-the-spectrix-s20g-pcie-gen3x4-m-2-2280-ssd%2F&#038;format=xml" />
<script type='text/javascript'>
	(function () {
		var pl_beacon = document.createElement('script');
		pl_beacon.type = 'text/javascript';
		pl_beacon.async = true;
		var host = 'https://wccftech.com';
		if ('https:' == document.location.protocol) {
			host = host.replace('http://', 'https://');
		}
		pl_beacon.src = host + '/' + 'cnt7vfDVvWa3' + '.js?ts=' + Math.floor((Math.random() * 100000) + 1);
		var first_script_tag = document.getElementsByTagName('script')[0];
		first_script_tag.parentNode.insertBefore(pl_beacon, first_script_tag);
	})();
</script>		<style>
			.algolia-search-highlight {
				background-color: #fffbcc;
				border-radius: 2px;
				font-style: normal;
			}
		</style>
		<link rel="amphtml" href="https://wccftech.com/xpg-announces-the-spectrix-s20g-pcie-gen3x4-m-2-2280-ssd/amp/">

<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
	
	ga('create', 'UA-3244067-1', 'auto');
	  ga('set', 'dimension1', 'Evan Federowicz');
  ga('set', 'dimension2', 'News,Sticky');
  ga('set', 'dimension3', '1608647940');
  ga('set', 'dimension4', 'post');
  ga('set', 'dimension8', 'Hardware');
	ga('send', 'pageview');
</script>

<style>
	@font-face {font-family: 'icomoon';  src: url('//cdn.wccftech.com/fonts/icomoon10.eot'); src: url('//cdn.wccftech.com/fonts/icomoon10.eot#iefix') format('embedded-opentype'), url('//cdn.wccftech.com/fonts/icomoon10.ttf') format('truetype'), url('//cdn.wccftech.com/fonts/fonts/icomoon10.woff') format('woff'), url('//cdn.wccftech.com/fonts/icomoon10.svg#icomoon') format('svg'); font-weight: normal; font-style: normal; }
</style>



<script>var mypage = 'news';
var mytopic = 'hardware';
</script>


	
		<script src="https://cmp.uniconsent.com/v2/stub.min.js"></script>
		<script async src='https://cmp.uniconsent.com/v2/4d73da7830/cmp.js'></script>
		<script type="text/javascript">
		window.googletag = window.googletag || {};
		window.googletag.cmd = window.googletag.cmd || [];
		window.googletag.cmd.push(function () {
		    window.googletag.pubads().enableAsyncRendering();
		    window.googletag.pubads().disableInitialLoad();
		});
		(adsbygoogle = window.adsbygoogle || []).pauseAdRequests = 1;
		</script>
		<script>
		__tcfapi("addEventListener", 2, function(tcData, success) {
		    if (success && tcData.unicLoad  === true) {
		        if(!window._initAds) {
					window._initAds = true;

					var script = document.createElement('script');
					script.async = true;
					script.src = 'https://d3lyxljmb9awzt.cloudfront.net/publishers/wccftechcom_new.min.js';
					document.head.appendChild(script);

					var script = document.createElement('script');
					script.async = true;
					script.src = 'https://pubgalaxy-com.videoplayerhub.com/gallery.js';
					document.head.appendChild(script);

		        }
		    }
		});
		</script>

		<script src="https://cdn.nsstatic.com/ns/wccftech.com.js" id="nsgpt" async="true"></script>

	


<!--[if lt IE 9]>
    <script src="//cdn.wccftech.com/files/html5shiv.min.js"></script>
<![endif]-->


	<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	<script type="text/javascript" src="https://native.sharethrough.com/assets/sfp.js"></script>



	<meta name="twitter:image" content="https://cdn.wccftech.com/wp-content/uploads/2020/12/hREM0v7n9sbjKmNx.jpg">

<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://wccftech.com/xpg-announces-the-spectrix-s20g-pcie-gen3x4-m-2-2280-ssd/"
  },
  "headline": "XPG Announces the SPECTRIX S20G PCIe Gen3x4 M.2 2280 SSD",
  "image": [
    "https://cdn.wccftech.com/wp-content/uploads/2020/12/hREM0v7n9sbjKmNx.jpg"
   ],
  "datePublished": "2020-12-22T19:39:00+00:00",
  "dateModified": "2020-12-22T19:48:25+00:00",
  "author": {
    "@type": "Person",
    "name": "Evan Federowicz"
  },
   "publisher": {
    "@type": "Organization",
    "name": "Wccftech",
    "url": "https://wccftech.com/",
    "logo": {
      "@type": "ImageObject",
      "url": "https://cdn.wccftech.com/wp-content/uploads/images/wccftech-logo.png"
    }
  },
  "description": "XPG has announced the XPG SPECTRIX S20G PCIe Gen3x4 M.2 2280 solid-state drive, which features a large amount of SSD lighting in an incredibly unique design read speeds of up to 2,500 MB per second. While these speeds aren't the fastest compared to other PCIe Gen3x4 SSDs, the RGB lighting looks to add more value [&amp;hellip;]"
}
</script>




</head>

<body class="post-template-default single single-post postid-1233985 single-format-standard">

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1503230403325633');
fbq('track', 'PageView');
</script><noscript><img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?id=1503230403325633&ev=PageView&noscript=1"/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->

<header>
	<section class="wrap clearfix">
		<a href="https://wccftech.com/"  rel="home"><div class="logo">Wccftech</div></a>

		<ul class="nav widget-analytics" data-event="Menu" data-page="Single">
			<li><a href="/category/news/"   title="See all news">News</a></li>
			<li><a href="/topic/hardware/"  title="See all hardware news">Hardware</a></li>
			<li><a href="/topic/games/"     title="See all gaming news">Gaming</a></li>
			<li><a href="/topic/gadgets/"   title="See all mobile news">Mobile</a></li>
			<li><a href="/topic/finance/"   title="See all finance news">Finance</a></li>
			<li><a href="/topic/deals/"     title="See all our deals posts">Deals</a></li>
			<li><a href="/review/"          title="See all reviews">Reviews</a></li>
			<li><a href="/videos/"  title="See all our youtube videos">Videos</a></li>
			<!--<li><a href="/topic/exclusive/"  title="See all our exclusive stories">Exclusives</a></li>-->
			<!--<li><a href="/pc-builder/"      title="PC Builder by Wccftech">PC Builder</a></li>-->
		</ul>
		<div class="toggle-search" title="Search"></div>
	</section>
	<div class="search-form">
		<form class="wrap" action="/find/"><input id="q" name="q" type="text" placeholder="What do you want to search for?" autocomplete="off"><input type="submit"></form>
	</div>
</header>

<div class="banner-ad" style="margin: 0 auto 40px auto;">
	<div id='div-gpt-ad-1454066633851-0' style="min-height:90px" class="position-ads"></div>	
</div>

<main class="wrap clearfix" style="">	

	<div class="clearfix">
	
    <section class="content">
	    		
		<div class="topics"><a href="https://wccftech.com/topic/hardware/" rel="tag">Hardware</a></div>
	
		<h1 class="page-heading">XPG Announces the SPECTRIX S20G PCIe Gen3x4 M.2 2280 SSD</h1>
			
	    <div class="single-meta">
		    <div class="meta-left">
				<div class="meta-author">By <a href="https://wccftech.com/author/evan/" title="Posts by Evan Federowicz" rel="author">Evan Federowicz</a></div>
			    <div class="meta-time">
					<time datetime="2020-12-22T19:39:00+00:00" title="Dec 22, 2020 14:39 EST">
						Dec 22, 2020 14:39 EST					</time>
														</div>
		    </div>
		    <div class="meta-share meta-share-top">
			    			    <span class="facebook"><i class="icon-facebook"></i> Share</span><span class="twitter"><i class="icon-twitter"></i> Tweet</span><span class="reddit"><i class="icon-reddit"></i> Submit</span>
			</div>
	    </div>
		
		<div class="body clearfix">
		
			<div class="wp-caption aligncenter featured-image"><div class="wp-lightbox"><a href="https://cdn.wccftech.com/wp-content/uploads/2020/12/hREM0v7n9sbjKmNx.jpg"><img width="740" height="740" src="https://cdn.wccftech.com/wp-content/uploads/2020/12/hREM0v7n9sbjKmNx-740x740.jpg" class="attachment-large size-large wp-post-image" alt="Spectrix S20G" loading="lazy" srcset="https://cdn.wccftech.com/wp-content/uploads/2020/12/hREM0v7n9sbjKmNx-740x740.jpg 740w, https://cdn.wccftech.com/wp-content/uploads/2020/12/hREM0v7n9sbjKmNx-410x410.jpg 410w, https://cdn.wccftech.com/wp-content/uploads/2020/12/hREM0v7n9sbjKmNx-768x768.jpg 768w, https://cdn.wccftech.com/wp-content/uploads/2020/12/hREM0v7n9sbjKmNx-820x820.jpg 820w, https://cdn.wccftech.com/wp-content/uploads/2020/12/hREM0v7n9sbjKmNx.jpg 960w" sizes="(max-width: 740px) 100vw, 740px" /></a></div><p class="wp-caption-text">Source: XPG</p></div>
			<p>XPG has announced the XPG SPECTRIX S20G PCIe Gen3x4 M.2 2280 solid-state drive, which features a large amount of SSD lighting in an incredibly unique design read speeds of up to 2,500 MB per second. While these speeds aren't the fastest compared to other PCIe Gen3x4 SSDs, the RGB lighting looks to add more value to this brand new SSD.</p>
<h2>The XPG SPECTRIX S20G SSD features a unique design and a large amount of RGB lighting</h2>
<p>The <a href="https://bit.ly/3mHAH4b">XPG</a> SPECTRIX S20G PCIe SSD is designed with gamers and gaming PCs in mind, and this is shown through the stylish design of the SSD and the large amount of RGB lighting present on the SSD. The design of this SSD features a distinctive and prominent X-shaped design. The SSD's large amount of RGB lighting can easily be customized through XPG's software, which has various effects and presets, which can be easily applied to the SSD.</p>
<p id="" class="wccf_related_post"><a class="wccf_related_post" href="https://wccftech.com/cooler-master-masterliquid-ml360-sub-zero-aio-thermoelectric-cooler-unveil/"> Cooler Master Releases The MasterLiquid ML360 Sub-Zero AIO Thermoelectric Cooler</a></p><div class="wp-caption clearfix alignnone"><div class="wp-lightbox"><img loading="lazy" class="size-full wp-image-1233992" src="https://cdn.wccftech.com/wp-content/uploads/2020/12/bdacUZaMc2myRVhg.jpg" alt="Spectrix S20G" width="960" height="960" srcset="https://cdn.wccftech.com/wp-content/uploads/2020/12/bdacUZaMc2myRVhg.jpg 960w, https://cdn.wccftech.com/wp-content/uploads/2020/12/bdacUZaMc2myRVhg-410x410.jpg 410w, https://cdn.wccftech.com/wp-content/uploads/2020/12/bdacUZaMc2myRVhg-740x740.jpg 740w, https://cdn.wccftech.com/wp-content/uploads/2020/12/bdacUZaMc2myRVhg-768x768.jpg 768w, https://cdn.wccftech.com/wp-content/uploads/2020/12/bdacUZaMc2myRVhg-820x820.jpg 820w" sizes="(max-width: 960px) 100vw, 960px"></div><div class="wp-caption-text">Source: XPG</div></div>
<p>This NVMe drive's size is 22 mm by 80 mm or M.2 2280, which is supported by a large majority of motherboards. This SSD features a weight of 10.4 grams or 0.37 oz.  This SSD is rated to come in two different capacities: either 500 GB or 1 TB, allowing gamers to purchase the size required by their computer system.</p>
<div id="" class="wccf_video_tag"><div id="div-gpt-ad-1586516229806-0"></div></div><p>The XPG SPECTRIX S20G PCIe SSD offers a sequential read speed of up to 2,500 MB/s and sequential writer speed of up to 1,800 MB/s allowing for faster loading and boot times for computers and games. This SSD uses the PCIe Gen3x4 interface to ensure that this SSD is NVMe 1.3-compliant. This SSD offers support for both the latest Intel and AMD platforms without the need to install any new drivers or software.</p>
<p>This SSD supports LDPC or Low-Density Parity-Check, error-correcting code technology that can detect and fix a range of data errors. This SSD features AES 256-bit encryption, which ensures that any data stored on this drive is protected and heavily encrypted.</p>
<p>While XPG has yet to announce pricing for the XPG SPECTRIX S20G PCIe SSD or when this SSD will be available for purchase, XPG has announced that this SSD will feature a five-year limited warranty.</p>			
						
		</div>

				
		
	    <div class="meta-share meta-share-bottom clearfix">
		    <span class="facebook"><i class="icon-facebook"></i> Share</span>
		    <span class="twitter"><i class="icon-twitter"></i> Tweet</span>
		    <span class="reddit"><i class="icon-reddit"></i> Submit</span>
		</div>

		

				

				
		<div style="margin: 50px auto" class="ad">
						<div class="subscribe clearfix">
	<div class="subscribe-cover">
		<p>Stay in the loop</p>
		<h3>GET A DAILY DIGEST OF LATEST TECHNOLOGY NEWS</h3>
		<p>Straight to your inbox</p>
	</div>
	<div class="subscribe-form">
		<p class="status">Subscribe to our newsletter</p>
		<form class="traqli" data-page="Single">
			<input type="email" id="sub_email" name="sub_email" placeholder="Enter your email" required /><input type="submit" value="Subscribe">
			<input type="hidden" name="action" value="submit_traqli">
		</form>		
	</div>
</div>

<link href="https://fonts.googleapis.com/css2?family=DM+Serif+Text&display=swap&text=GET%20A%20DAILY%20DIGEST%20OF%20LATEST%20TECHNOLOGY%20NEWS" rel="stylesheet">

<style>
.subscribe { border: 2px solid #EB0254; position: relative; margin: 125px 0; margin-left: -62px; margin-right: -62px; min-height: 100px }
.subscribe-cover { float:left; width:150px; background-color: #222; margin: -65px 0 -65px 35px; text-align: center; padding: 50px 15px; color: white; min-width: 290px; }
	.subscribe-cover img { margin-bottom: 20px }
	.subscribe-cover h3 { font-family: 'DM Serif Text', serif; margin-bottom: 15px; font-weight: normal; font-size: 30px }
	.subscribe-cover p { font-size: 12px;  color: #aaa; margin-bottom: 0; }
	.subscribe-cover p:first-child { margin-bottom: 15px; }

.subscribe-form  { padding: 40px; width: 100%; padding-left: 361px; }
	.subscribe-form p { font-weight: bold; margin-bottom: 15px; }
	.subscribe-form form { width: 100%; background: #eee; padding: 10px; border-radius: 10px }
	.subscribe-form form input { font-size: 14px; border:none; border-radius: 0; background-color: #eee }
	.subscribe-form form input:-webkit-autofill, .subscribe-form form input:focus:-webkit-autofill { -webkit-box-shadow: 0 0 0 100px rgb(238, 238, 238) inset; }
	.subscribe-form form input[type=email]  { width: 75%; padding: 10px; }
	.subscribe-form form input[type=submit] { width: 25%; padding: 10px 0; background: #EB0254; color: #fff; -webkit-appearance: none; border-radius: 25px }
	.subscribe-form form input[type=submit]:hover { background: #d2024b  }

@media only screen and (max-width: 1850px) {
	.subscribe {margin-left: -46px; margin-right: -46px;}
	.subscribe-cover { margin-left: 20px; }
	.subscribe-form { padding: 40px 23px; padding-left: 333px; }
}
</style>
		</div>

		<style>.subscribe { margin-top: 100px; }</style>
		
		
						
								
				<div class="related-posts widget-analytics clearfix" data-event="Related" data-page="Single" style="margin-top: 30px;">
					<h2 class="sub-head"><span>Related</span></h2>
					
	<div id='div-gpt-ad-1583497834297-0'></div>
		
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/addlink-introduces-the-s68-m-2-nvme-ssd-series/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2020/05/feature-1-240x135.jpg" alt="feature-5" srcset="https://cdn.wccftech.com/wp-content/uploads/2020/05/feature-1-480x270.jpg 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/addlink-introduces-the-s68-m-2-nvme-ssd-series/">Addlink Introduces the S68 M.2 NVMe SSD Series</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/evan/">Evan Federowicz</a> &nbsp;•&nbsp; Jun 2, 2020					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1174629 http://wccftech.com/?p=1174629"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/seagate-releases-the-firecuda-120-sata-ssd-designed-with-gamers-in-mind/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2020/05/EY9kc1CXkAAoSjM-240x135.jpg" alt="ey9kc1cxkaaosjm" srcset="https://cdn.wccftech.com/wp-content/uploads/2020/05/EY9kc1CXkAAoSjM-480x270.jpg 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/seagate-releases-the-firecuda-120-sata-ssd-designed-with-gamers-in-mind/">Seagate Releases the FireCuda 120 SATA SSD Designed With Gamers in Mind</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/evan/">Evan Federowicz</a> &nbsp;•&nbsp; May 30, 2020					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1174444 http://wccftech.com/?p=1174444"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/the-aorus-nvme-gen4-500-gb-ssd-is-currently-on-sale-for-129-us/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2019/05/AORUS-NVMe-Gen-4-SSD-2-TB_1-240x135.jpeg" alt="aorus-nvme-gen-4-ssd-2-tb_1" srcset="https://cdn.wccftech.com/wp-content/uploads/2019/05/AORUS-NVMe-Gen-4-SSD-2-TB_1-480x270.jpeg 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/the-aorus-nvme-gen4-500-gb-ssd-is-currently-on-sale-for-129-us/">The AORUS NVMe Gen4 500 GB SSD is Currently On Sale For $129 US</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/evan/">Evan Federowicz</a> &nbsp;•&nbsp; Apr 19, 2020					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1160755 http://wccftech.com/?p=1160755"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/asrock-rack-announces-the-m2_vga-graphics-card/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2020/12/Untitled-240x135.png" alt="untitled-70" srcset="https://cdn.wccftech.com/wp-content/uploads/2020/12/Untitled-480x270.png 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/asrock-rack-announces-the-m2_vga-graphics-card/">ASRock Rack Announces the M2_VGA Graphics Card</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/evan/">Evan Federowicz</a> &nbsp;•&nbsp; Dec 14					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1231633 http://wccftech.com/?p=1231633"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/adata-xpg-announces-the-xpg-levante-360-aio-cooler/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2020/12/productGallery7714-240x135.jpg" alt="productgallery7714" srcset="https://cdn.wccftech.com/wp-content/uploads/2020/12/productGallery7714-480x270.jpg 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/adata-xpg-announces-the-xpg-levante-360-aio-cooler/">ADATA XPG Announces the XPG LEVANTE 360 AIO Cooler</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/evan/">Evan Federowicz</a> &nbsp;•&nbsp; Dec 4					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1229401 http://wccftech.com/?p=1229401"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
					</div>

				
		
				<div id="disqus_thread"></div>
		<script>
			var disquspageurl = 'https://wccftech.com/xpg-announces-the-spectrix-s20g-pcie-gen3x4-m-2-2280-ssd/';
			var disqus_config = function () {
				this.page.url = disquspageurl;
				this.page.identifier = '1233985 http://wccftech.com/?p=1233985';
				this.callbacks.onNewComment = [function(comment) {
					if (typeof ga !== 'undefined') ga( 'send', 'event', 'Comments', 'Single', disquspageurl );
				}];
			};

			(function() {
				var d = document, s = d.createElement('script');
				s.src = '//wccftech.disqus.com/embed.js';
				s.setAttribute('data-timestamp', +new Date());
				(d.head || d.body).appendChild(s);
			})();
		</script>
		<noscript>Please enable JavaScript to view the comments.</noscript>
				

	</section>
    
        
	<aside class="sidebar">
		
	
		<div class="sidebar-ad">
			<div id='div-gpt-ad-1454066633851-2' style='height:250px; width:300px;'></div>
		</div>

		

		

	<section class="trending-posts sidebar-trending widget-analytics" data-event="Trending" data-page="Single">
		<h3 class="sub-head"><span>Trending Stories</span></h3>
		<ul><li><a href="https://wccftech.com/rumor-nvidias-next-generation-5nm-gpu-architecture-to-be-called-lovelace-hopper-mcm-gpu-delayed/">Rumor: NVIDIA&#8217;s Next Generation 5nm GPU Architecture To Be Called Lovelace, Hopper MCM GPU Delayed?</a></li>
<li><a href="https://wccftech.com/amd-zen-3-ryzen-5000-cpus-twice-as-fast-as-original-zen-architecture/">AMD Zen 3 Based Ryzen 5000 CPUs Achieved A Massive 89% Performance Improvement Over The Original Zen Architecture</a></li>
<li><a href="https://wccftech.com/asus-geforce-rtx-3090-rog-strix-gundam-edition-graphics-card-pictured-again/">ASUS GeForce RTX 3090 ROG STRIX GUNDAM Edition Graphics Card Pictured Again, Designed For Collectors &#038; Priced at $2600 US</a></li>
<li><a href="https://wccftech.com/cyberpunk-2077-1-05-update-delivered-significant-improvements-on-consoles/">Cyberpunk 2077 1.05 Update Delivered Significant Improvements on Consoles</a></li>
<li><a href="https://wccftech.com/geforce-hotfix-driver-490-97-released-by-nvidia-fixes-hdr-black-levels-and-stuttering-in-marvels-avengers/">GeForce Hotfix Driver 490.97 Released by NVIDIA, Fixes HDR Black Levels and Stuttering in Marvel&#8217;s Avengers</a></li>
</ul>	</section>

	
	
		<div class="sidebar-ad">
			<div id='div-gpt-ad-1454066633851-7' style='height:600px; width:300px;'></div>
		</div>

		
	<section class="popular-posts sidebar-popular widget-analytics" data-event="Popular" data-page="Single">
		<h3 class="sub-head"><span>Popular Discussions</span></h3>
		<ul><li class="popular-post-1"><a href="https://wccftech.com/intel-core-i9-11900-8-core-rocket-lake-desktop-cpu-benchmarks-leak-out/">Intel Core i9-11900 8 Core Rocket Lake Desktop CPU Benchmarks Leak Out, Early ES Chip With 1.8 GHz Clocks Tested on Z490 Platform</a><span>3631</span></li>
<li class="popular-post-2"><a href="https://wccftech.com/rumor-nvidias-next-generation-5nm-gpu-architecture-to-be-called-lovelace-hopper-mcm-gpu-delayed/">Rumor: NVIDIA&#8217;s Next Generation 5nm GPU Architecture To Be Called Lovelace, Hopper MCM GPU Delayed?</a><span>2145</span></li>
<li class="popular-post-3"><a href="https://wccftech.com/sapphire-radeon-rx-6900-xt-nitro-flagship-big-navi-graphics-card-unveiled/">Sapphire Radeon RX 6900 XT Nitro+ Flagship Big Navi Graphics Card Unveiled, Features Triple-Fan Cooling &#038; A Small Factory Overclock</a><span>1760</span></li>
<li class="popular-post-4"><a href="https://wccftech.com/report-nvidia-rtx-30-super-series-to-be-manufactured-by-samsung-as-well/">Report: NVIDIA RTX 30 SUPER Series To Be Manufactured By Samsung As Well</a><span>1624</span></li>
<li class="popular-post-5"><a href="https://wccftech.com/intel-core-i9-11900-8-core-rocket-lake-desktop-cpu-benchmarks-leak-out-leads-in-single-threaded-workloads/">Intel Core i9-11900 8 Core Rocket Lake Desktop CPU Benchmarks Leak Out Again, Leads In Single-Threaded Workloads</a><span>1431</span></li>
</ul>	</section>

	<section class="latest-posts sidebar-deals widget-analytics" data-event="Deals (Sidebar)" data-page="Single">
	<h3 class="sub-head"><span>Wccftech Store</span></h3>

<ul>
		
	<li class="clearfix first">
		<a href="https://wccftech.com/complete-cryptocurrency-professional-trading-bundle-limited/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2020/12/Complete-Cryptocurrency-Professional-Trading-Bundle-480x270.jpg"></div>
			<h4>Complete Cryptocurrency Professional Trading Bundle Is Up For A Massive Discount Offer &#8211; Avail Now</h4>
		</a>
	</li>
	
		
	<li class="clearfix ">
		<a href="https://wccftech.com/2021-ultimate-digital-marketing-super-bundle-limited/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2020/12/2021-Ultimate-Digital-Marketing-Super-Bundle-86x60.jpg"></div>
			<h4>2021 Ultimate Digital Marketing Super Bundle Is Going To Help You Embrace These Most Sought After Skills &#8211; Avail Offer Now</h4>
		</a>
	</li>
	
		
	<li class="clearfix ">
		<a href="https://wccftech.com/ultimate-microsoft-programmer-bundle-limited/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2020/12/Ultimate-Microsoft-.NET-C-Programmer-Bundle-86x60.jpg"></div>
			<h4>Ultimate Microsoft Programmer Bundle Is Up For An Amazing Offer For A Few Days &#8211; Get It Now</h4>
		</a>
	</li>
	
		
	<li class="clearfix ">
		<a href="https://wccftech.com/mobile-pixels-duex-pro-portable-dual-monitor-discount/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2020/12/Mobile-Pixels-DUEX-Pro-Portable-Dual-Monitor-86x60.jpg"></div>
			<h4>Mobile Pixels DUEX Pro Portable Dual Monitor Is Up For A Limited Time Discount &#8211; Avail Now</h4>
		</a>
	</li>
	
		
	<li class="clearfix ">
		<a href="https://wccftech.com/official-cyber-monday-mac-bundle-ft-parallels-pro-luminar-4-is-the-best-way-to-increase-productivity-offer-expires-in-a-few-hours/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2020/12/Official-Cyber-Monday-Mac-Bundle-1-86x60.jpg"></div>
			<h4>Official Cyber Monday Mac Bundle Ft. Parallels Pro &#038; Luminar 4 Is The Best Way To Increase Productivity &#8211; Offer Expires In A Few Hours</h4>
		</a>
	</li>
	
	</ul>	</section>

	
</aside><!-- end aside class sidebar -->
    </div><!-- end clearfix -->

</main>

<footer data-nosnippet>

    <section class="wrap clearfix">
				
				
		<div class="footer-1">
			<!--<i class="fa fa-folder-open-o"></i>-->
			<h3>Sections</h3>
			<ul>
				<li><a href="/review/">Reviews</a></li>
				<li><a href="/videos/">Videos</a></li>
				<li><a href="/how-to/">How To's</a></li>
				<li><a href="/topic/exclusive/">Exclusives</a></li>
				<li><a href="/topic/interview/">Interviews</a></li>
				<li><a href="/topic/deals/">Deals</a></li>
				<li><a href="/topic/entertainment/">Entertainment</a></li>
				<li><a href="/pc-builder/">PC Builder</a></li>
			</ul>
		</div>
		
		<div class="footer-2">
			<!--<i class="fa fa-hashtag"></i>-->
			<h3>Topics</h3>
			<ul>
				<li><a href="/topic/hardware/">Hardware</a></li>
				<li><a href="/topic/games/">Gaming</a></li>
				<li><a href="/topic/gadgets/">Mobile</a></li>
				<li><a href="/topic/finance/">Finance</a></li>
				<li><a href="/topic/software/">Software</a></li>
				<li><a href="/topic/security/">Security</a></li>
				<li><a href="/topic/web/">Web</a></li>
			</ul>
		</div>
		
		<div class="footer-3">
			<!--<i class="fa fa-info"></i>-->
			<h3>Know Us</h3>
			<ul>
				<li><a href="/about/">About</a></li>
				<li><a href="/advertise/">Advertise</a></li>
				<li><a href="/contact/">Contact</a></li>
				<li><a href="/tip-us/">Tip Us</a></li>
				<li><a href="/jobs/">Careers</a></li>
				<li><a href="/legal-disclaimer/">Terms of Use</a></li>
				<li><a href="/privacy-policy/">Privacy &amp; Cookie Policy</a></li>
				<li><a href="/ethics-statement/">Ethics Statement</a></li>
				<li>
					<script>
					(function waitGEO() {
					    var readyGEO;
					    if (window['UnicI'] && window['UnicI'].geo && window['UnicI'].geo !== '-' ) {
					        readyGEO = true;
					        console.log(window['UnicI'].geo);
					        if (window['UnicI'].geo === 'EU') {
					            if(document.getElementById("unic-gdpr")) {
					              document.getElementById("unic-gdpr").style.display = 'block';
					            }
					        }
					        if (window['UnicI'].geo === 'CA') {
					            if(document.getElementById("unic-ccpa")) {
					              document.getElementById("unic-ccpa").style.display = 'block';
					            }
					        }
					    }
					    if (!readyGEO) {
					        setTimeout(waitGEO, 200);
					    }
					})();
					</script>
					<a id='unic-gdpr' onclick='__tcfapi("openunic");return false;' style='display:none;cursor:pointer;'>Change Ad Consent</a>
					<a id='unic-ccpa' onclick="window.__uspapi('openunic')" style='display:none;cursor:pointer;'>Do not sell my data</a>
				</li>
			</ul>
		</div>

		<div class="footer-4">
			<!--<i class="fa"></i>-->
			<h3>Follow US</h3>
			<ul>
				<li class="twitter"><a href="https://twitter.com/wccftech"><i class="icon-twitter"></i> Twitter</a></li>
				<li class="facebook"><a href="https://www.facebook.com/wccftech"><i class="icon-facebook"></i> Facebook</a></li>
				<li class="youtube"><a href="https://www.youtube.com/wccftechtv"><i class="icon-youtube"></i> YouTube</a></li>
			</ul><br><br>

			<div>
				<h3 style="margin-bottom: 10px;">Subscribe</h3>
				<p class="status">For latest tech news in your inbox, once a day!</p>
				<form class="traqli" data-page="Single">
					<input type="email" id="sub_email" name="sub_email" placeholder="Email address" required /><input type="submit" value="Subscribe">
					<input type="hidden" name="action" value="submit_traqli">
				</form>
			</div>
		</div>

		<div class="copyright">
			<span class="logo"><a href="https://wccftech.com/" rel="home">Wccftech</a></span>
			<span class="text">
				&copy; 2020 NewAge ADS, LLC. All rights reserved.
			</span>
			<span class="preload-images"></span>
		</div>

		<div class="disclaimer">Some posts on Wccftech.com may contain affiliate links. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to Amazon.com</div>

    </section>
</footer>

<script type="text/javascript">var algolia = {"debug":false,"application_id":"JP6Z5G2P43","search_api_key":"4784f5ddc534ec220ede8a86867f33c7","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"searchable_posts","index_name":"wp_searchable_posts","label":"All posts","admin_name":"All posts","position":10,"max_suggestions":5,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"wp_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]}}};</script><script type='text/javascript' src='https://cdn.wccftech.com/wp-content/themes/wccf2016/script.js?ver=1608003897' id='wccf-script-js'></script>
<script type='text/javascript' src='https://cdn.wccftech.com/wp-content/themes/wccf2016/footer.js?ver=1608003897' id='wccf-footer-js'></script>

<script type="text/javascript" src="https://s.skimresources.com/js/31026X886738.skimlinks.js"></script>
<div id="amzn-assoc-ad-54373194-91c7-4e61-b9a0-12cad6711106"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=54373194-91c7-4e61-b9a0-12cad6711106"></script>

<!-- /8095840/.2_12459.46_wccftech.com_tier1 -->
<div id='div-gpt-ad-1559306343883-0' style='height:1px; width:1px;'>
<script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1559306343883-0'); });</script>
</div>

<script id="dsq-count-scr" src="//wccftech.disqus.com/count.js" async></script>

<script type="text/javascript">
;!function(){
    window.NewzmateConfig = {
        id: 83
    }
    var e=document.createElement("script");e.setAttribute("id","tqlucidsdksel"),e.type="text/javascript",e.src="//api.traq.li/public/sdk/v04/sdk.js?v="+(localStorage&&localStorage.lucidsdkver||"xxx"),e.async=!0,document.getElementsByTagName("script")[0].parentNode.appendChild(e);
}();
</script>


<style>
	.mpp-toc-container { max-width: 100%; padding: 0; width: 100%; border: none; margin: 0; }
	.mpp-toc-title h2 { text-align: left; margin-top: 0; margin-bottom: 0; color: white; }
	.mpp-toc-title { padding: 10px 15px; background: #EB0254; color: white; }
	.mpp-toc { padding: 15px; background: white; border: 1px solid #EB0254; }
	.mpp-toc-container ul li { margin-bottom: 5px; }
	.mpp-page-link { display: inline; float: right; }
	.mpp-page-link a { color: white }
	nav.mpp-post-navigation .nav-links a { font-size: 80%; text-transform: uppercase; padding: 5px 0; width: auto; }
	nav.mpp-post-navigation .nav-links a:hover { border: none; text-decoration: underline; }
	nav.mpp-post-navigation .nav-links a[rel="next"]:after { content: '\00bb'; padding-left: 10px; }
	nav.mpp-post-navigation .nav-links a[rel="previous"]:before { content: '\00ab'; padding-right: 10px; }
</style>

<script src="//dsh7ky7308k4b.cloudfront.net/autoads/wccftechcom-single.min.js"></script>

<style>
.qc-cmp-persistent-link {display: none !important;}
</style>
</body>
</html>
