<!DOCTYPE html>
<html lang="en-US">
<head>

<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=no">
<meta property="fb:app_id" content="58923144965" />
<meta property="fb:pages" content="71411645007" />
<meta name="author" content="Aernout van de Velde" />
<link rel="shortcut icon" type='image/x-icon' href="https://wccftech.com/favicon.ico" />
<link rel="apple-touch-icon" sizes="180x180" href="https://wccftech.com/icons/apple-touch-icon.png">
<link rel="icon" type="image/png" href="https://wccftech.com/icons/favicon-32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="https://wccftech.com/icons/favicon-16x16.png" sizes="16x16">
<link rel="manifest" href="https://wccftech.com/icons/manifest.json">
<link rel="mask-icon" href="https://wccftech.com/icons/safari-pinned-tab.svg" color="#5bbad5">
<meta name="apple-mobile-web-app-title" content="Wccftech">
<meta name="application-name" content="Wccftech">
<meta name="theme-color" content="#ffffff">

<style>@import url('https://fonts.googleapis.com/css?family=Fira+Sans:400,500|Open+Sans:400,700');</style>


<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO Premium plugin v16.3 (Yoast SEO v16.3) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>New DOOM Eternal Update 6.1 Packs Platform-Specific Improvements and Fixes Across Xbox Series X|S, PlayStation and PC</title>
	<link rel="canonical" href="https://wccftech.com/new-doom-eternal-update-6-1/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="New DOOM Eternal Update 6.1 Packs Platform-Specific Improvements and Fixes Across Xbox Series X|S, PlayStation and PC" />
	<meta property="og:description" content="Bethesda and id Software have rolled out DOOM Eternal update 6.1, which packs platform-specific improvements and fixes. Following the recently-released next-gen update, this new patch is a minor one. Still, the patch addresses several campaign and Battlemode issues. In addition, this new update fixes an issue for players with AMD GPUs and allows setups with [&hellip;]" />
	<meta property="og:url" content="https://wccftech.com/new-doom-eternal-update-6-1/" />
	<meta property="og:site_name" content="Wccftech" />
	<meta property="article:publisher" content="https://www.facebook.com/wccftech" />
	<meta property="article:author" content="https://www.facebook.com/a3rnout" />
	<meta property="article:published_time" content="2021-07-15T07:01:14+00:00" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@A3rnout" />
	<meta name="twitter:site" content="@wccftech" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Aernout van de Velde">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="2 minutes">
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Wccftech &raquo; Feed" href="https://wccftech.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Wccftech &raquo; Comments Feed" href="https://wccftech.com/comments/feed/" />
<link rel='stylesheet' id='wccf-main-css'  href='https://cdn.wccftech.com/wp-content/themes/wccf2016/style.css?ver=1625257245' type='text/css' media='all' />
<link rel='stylesheet' id='wccf-style-single-css'  href='https://cdn.wccftech.com/wp-content/themes/wccf2016/style-single.css?ver=1625257245' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://wccftech.com/wp-json/" /><link rel="alternate" type="application/json" href="https://wccftech.com/wp-json/wp/v2/posts/1279204" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://wccftech.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cdn.wccftech.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.1" />
<link rel='shortlink' href='https://wccftech.com/?p=1279204' />
<link rel="alternate" type="application/json+oembed" href="https://wccftech.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwccftech.com%2Fnew-doom-eternal-update-6-1%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://wccftech.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwccftech.com%2Fnew-doom-eternal-update-6-1%2F&#038;format=xml" />
<script type='text/javascript'>
	(function () {
		var pl_beacon = document.createElement('script');
		pl_beacon.type = 'text/javascript';
		pl_beacon.async = true;
		var host = 'https://wccftech.com';
		if ('https:' == document.location.protocol) {
			host = host.replace('http://', 'https://');
		}
		pl_beacon.src = host + '/' + 'cnt7vfDVvWa3' + '.js?ts=' + Math.floor((Math.random() * 100000) + 1);
		var first_script_tag = document.getElementsByTagName('script')[0];
		first_script_tag.parentNode.insertBefore(pl_beacon, first_script_tag);
	})();
</script>		<style>
			.algolia-search-highlight {
				background-color: #fffbcc;
				border-radius: 2px;
				font-style: normal;
			}
		</style>
		<link rel="amphtml" href="https://wccftech.com/new-doom-eternal-update-6-1/amp/">

<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
	
	ga('create', 'UA-3244067-1', 'auto');
	  ga('set', 'dimension1', 'Aernout van de Velde');
  ga('set', 'dimension2', 'News,Sticky');
  ga('set', 'dimension3', '1626318074');
  ga('set', 'dimension4', 'post');
  ga('set', 'dimension8', 'Gaming');
	ga('send', 'pageview');
</script>

<style>
	@font-face {font-family: 'icomoon';  src: url('//cdn.wccftech.com/fonts/icomoon10.eot'); src: url('//cdn.wccftech.com/fonts/icomoon10.eot#iefix') format('embedded-opentype'), url('//cdn.wccftech.com/fonts/icomoon10.ttf') format('truetype'), url('//cdn.wccftech.com/fonts/fonts/icomoon10.woff') format('woff'), url('//cdn.wccftech.com/fonts/icomoon10.svg#icomoon') format('svg'); font-weight: normal; font-style: normal; }
</style>



<script>var mypage = 'news';
var mytopic = 'games';
</script>


	
		<script src="https://cmp.uniconsent.com/v2/stub.min.js"></script>
		<script async src='https://cmp.uniconsent.com/v2/4d73da7830/cmp.js'></script>
		<script type="text/javascript">
		window.googletag = window.googletag || {};
		window.googletag.cmd = window.googletag.cmd || [];
		window.googletag.cmd.push(function () {
		    window.googletag.pubads().enableAsyncRendering();
		    window.googletag.pubads().disableInitialLoad();
		});
		(adsbygoogle = window.adsbygoogle || []).pauseAdRequests = 1;
		</script>
		<script>
		__tcfapi("addEventListener", 2, function(tcData, success) {
		    if (success && tcData.unicLoad  === true) {
		        if(!window._initAds) {
					window._initAds = true;

					var script = document.createElement('script');
					script.async = true;
					script.src = 'https://dsh7ky7308k4b.cloudfront.net/publishers/wccftechcom_new.min.js?234568';
					document.head.appendChild(script);

					var script = document.createElement('script');
					script.async = true;
					script.src = 'https://pubgalaxy-com.videoplayerhub.com/gallery.js';
					document.head.appendChild(script);

		        }
		    }
		});
		</script>

		<script src="https://cdn.nsstatic.com/ns/wccftech.com.js" id="nsgpt" async="true"></script>

	


<!--[if lt IE 9]>
    <script src="//cdn.wccftech.com/files/html5shiv.min.js"></script>
<![endif]-->


	<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	<script type="text/javascript" src="https://native.sharethrough.com/assets/sfp.js"></script>



	<meta name="twitter:image" content="https://cdn.wccftech.com/wp-content/uploads/2021/06/doom-eternal-geforce-rtx-ray-traced-reflections-006-off-1920px-740x416.jpg">

<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://wccftech.com/new-doom-eternal-update-6-1/"
  },
  "headline": "New DOOM Eternal Update 6.1 Packs Platform-Specific Improvements and Fixes Across Xbox Series X|S, PlayStation and PC",
  "image": [
    "https://cdn.wccftech.com/wp-content/uploads/2021/06/doom-eternal-geforce-rtx-ray-traced-reflections-006-off-1920px.jpg"
   ],
  "datePublished": "2021-07-15T07:01:14+00:00",
  "dateModified": "2021-07-15T07:01:14+00:00",
  "author": {
    "@type": "Person",
    "name": "Aernout van de Velde"
  },
   "publisher": {
    "@type": "Organization",
    "name": "Wccftech",
    "url": "https://wccftech.com/",
    "logo": {
      "@type": "ImageObject",
      "url": "https://cdn.wccftech.com/wp-content/uploads/images/wccftech-logo.png"
    }
  },
  "description": "Bethesda and id Software have rolled out DOOM Eternal update 6.1, which packs platform-specific improvements and fixes. Following the recently-released next-gen update, this new patch is a minor one. Still, the patch addresses several campaign and Battlemode issues. In addition, this new update fixes an issue for players with AMD GPUs and allows setups with [&amp;hellip;]"
}
</script>




</head>

<body class="post-template-default single single-post postid-1279204 single-format-standard">

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1503230403325633');
fbq('track', 'PageView');
</script><noscript><img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?id=1503230403325633&ev=PageView&noscript=1"/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->

<header>
	<section class="wrap clearfix">
		<a href="https://wccftech.com/"  rel="home"><div class="logo">Wccftech</div></a>

		<ul class="nav widget-analytics" data-event="Menu" data-page="Single">
			<li><a href="/category/news/"   title="See all news">News</a></li>
			<li><a href="/topic/hardware/"  title="See all hardware news">Hardware</a></li>
			<li><a href="/topic/games/"     title="See all gaming news">Gaming</a></li>
			<li><a href="/topic/gadgets/"   title="See all mobile news">Mobile</a></li>
			<li><a href="/topic/finance/"   title="See all finance news">Finance</a></li>
			<li><a href="/topic/deals/"     title="See all our deals posts">Deals</a></li>
			<li><a href="/review/"          title="See all reviews">Reviews</a></li>
			<li><a href="/videos/"  title="See all our youtube videos">Videos</a></li>
			<!--<li><a href="/topic/exclusive/"  title="See all our exclusive stories">Exclusives</a></li>-->
			<!--<li><a href="/pc-builder/"      title="PC Builder by Wccftech">PC Builder</a></li>-->
		</ul>
		<div class="toggle-search" title="Search"></div>
	</section>
	<div class="search-form">
		<form class="wrap" action="/find/"><input id="q" name="q" type="text" placeholder="What do you want to search for?" autocomplete="off"><input type="submit"></form>
	</div>
</header>

<div class="banner-ad">
	<div id='div-gpt-ad-1454066633851-0'></div>
	<div id='div-gpt-ad-wccftechcom38568'></div>
</div>

<main class="wrap clearfix" style="">	

	<div class="clearfix">
	
    <section class="content">
	    		
		<div class="topics"><a href="https://wccftech.com/topic/games/" rel="tag">Gaming</a></div>
	
		<h1 class="page-heading">New DOOM Eternal Update 6.1 Packs Platform-Specific Improvements and Fixes Across Xbox Series X|S, PlayStation and PC</h1>
			
	    <div class="single-meta">
		    <div class="meta-left">
				<div class="meta-author">By <a href="https://wccftech.com/author/aernout/">Aernout van de Velde</a></div>
			    <div class="meta-time">
					<time datetime="2021-07-15T07:01:14+00:00" title="Jul 15, 2021 03:01 EDT">
						Jul 15, 2021 03:01 EDT					</time>
														</div>
		    </div>
		    <div class="meta-share meta-share-top">
			    			    <span class="facebook"><i class="icon-facebook"></i> Share</span><span class="twitter"><i class="icon-twitter"></i> Tweet</span><span class="reddit"><i class="icon-reddit"></i> Submit</span>
			</div>
	    </div>
		
		<div class="body clearfix">
		
			<div class="wp-caption aligncenter featured-image"><div class="wp-lightbox"><a href="https://cdn.wccftech.com/wp-content/uploads/2021/06/doom-eternal-geforce-rtx-ray-traced-reflections-006-off-1920px.jpg"><img width="740" height="416" src="https://cdn.wccftech.com/wp-content/uploads/2021/06/doom-eternal-geforce-rtx-ray-traced-reflections-006-off-1920px-740x416.jpg" class="attachment-large size-large wp-post-image" alt="DOOM Eternal update 6.1" loading="lazy" srcset="https://cdn.wccftech.com/wp-content/uploads/2021/06/doom-eternal-geforce-rtx-ray-traced-reflections-006-off-1920px-740x416.jpg 740w, https://cdn.wccftech.com/wp-content/uploads/2021/06/doom-eternal-geforce-rtx-ray-traced-reflections-006-off-1920px-410x231.jpg 410w, https://cdn.wccftech.com/wp-content/uploads/2021/06/doom-eternal-geforce-rtx-ray-traced-reflections-006-off-1920px-240x135.jpg 240w, https://cdn.wccftech.com/wp-content/uploads/2021/06/doom-eternal-geforce-rtx-ray-traced-reflections-006-off-1920px-768x432.jpg 768w, https://cdn.wccftech.com/wp-content/uploads/2021/06/doom-eternal-geforce-rtx-ray-traced-reflections-006-off-1920px-1536x864.jpg 1536w, https://cdn.wccftech.com/wp-content/uploads/2021/06/doom-eternal-geforce-rtx-ray-traced-reflections-006-off-1920px-480x270.jpg 480w, https://cdn.wccftech.com/wp-content/uploads/2021/06/doom-eternal-geforce-rtx-ray-traced-reflections-006-off-1920px-820x461.jpg 820w, https://cdn.wccftech.com/wp-content/uploads/2021/06/doom-eternal-geforce-rtx-ray-traced-reflections-006-off-1920px-1480x833.jpg 1480w, https://cdn.wccftech.com/wp-content/uploads/2021/06/doom-eternal-geforce-rtx-ray-traced-reflections-006-off-1920px-1030x579.jpg 1030w, https://cdn.wccftech.com/wp-content/uploads/2021/06/doom-eternal-geforce-rtx-ray-traced-reflections-006-off-1920px.jpg 1920w" sizes="(max-width: 740px) 100vw, 740px" /></a></div></div>
			<p>Bethesda and id Software have rolled out DOOM Eternal update 6.1, which packs platform-specific improvements and fixes.</p>
<p>Following the recently-released next-gen update, this new patch is a minor one. Still, the patch addresses several campaign and Battlemode issues. In addition, this new update fixes an issue for players with AMD GPUs and allows setups with mobile graphic cards to enable Ray Tracing if the GPU supports it.</p>
<p id="" class="wccf_related_post"><a class="wccf_related_post" href="https://wccftech.com/deathloop-gameplay-footage-9-minutes/"> Deathloop Showcases Slick Dishonored-Like Action in 9 Minutes of New Footage</a></p><div id="" class="wccf_video_tag"><div id="div-gpt-ad-1586516229806-0"></div></div><p>You’ll find the <a href="https://slayersclub.bethesda.net/en/article/1I3ERZDagbNmtHafZCWQbU/doom-eternal-update-6.1" target="_blank" rel="noopener">full release notes</a> down below:</p>
<blockquote>
<h3>DOOM Eternal Update 6.1 Release Notes Xbox Series X|S, PlayStation 4/5, PC</h3>
<p><strong>Campaign All Platforms</strong></p>
<ul><li>Fixed a bug where bullets would collide with gore and ammo pickups during combat</li>
<li>Fixed a bug with Cacodemon pathing during the boss encounter in The Holt in The Ancient Gods - Part One</li>
</ul><p><strong>Campaign Xbox Series X|S Only</strong></p>
<ul><li>The controls menu now displays the correct controller image for Xbox Series X|S</li>
</ul><p><strong>Campaign PlayStation Only</strong></p>
<ul><li>Fixed an issue where PlayStation users were prevented from rejoining private matches after being disconnected</li>
</ul><p><strong>PC Only</strong></p>
<ul><li>Fixed a crash that occurred when selecting the Challenges tab in the pause menu</li>
<li>Fixed the issue players with AMD GPUs were having that caused artifacting in a number of environments</li>
<li>PCs with mobile GPUs that support ray tracing can now enable this feature</li>
</ul><p><strong>BATTLEMODE All Platforms</strong></p>
<ul><li>Fixed an issue where the Slayer’s weapon skins displayed the wrong customization options</li>
<li>Fixed an issue where Demon players would become invisible to other demons when respawning with ray tracing enabled</li>
<li>Fixed Demon interface for Latin Spanish users with modified controller settings</li>
<li>Fixed an issue with the social menu preventing players from selecting another player with only one favorite or friend in the list</li>
</ul></blockquote>
<p>DOOM Eternal is available now across PC and consoles. Last <a href="https://wccftech.com/doom-eternal-xbox-series-xs-update-ps5/">month’s next-gen update</a> offers increased performance, enhanced visuals, and support for ray-tracing, or 4K resolution at 60 frames per second, or an optional 120 FPS mode. On PC, <a href="https://wccftech.com/nvidia-adds-raytracing-and-dlss-2-0-support-for-doom-eternal-with-up-to-50-performance-increase/" target="_blank" rel="noopener">the update added support for Ray Tracing and NVIDIA's DLSS 2.0</a>.</p>			
						
		</div>

		
				
		
	    <div class="meta-share meta-share-bottom clearfix">
		    <span class="facebook"><i class="icon-facebook"></i> Share</span>
		    <span class="twitter"><i class="icon-twitter"></i> Tweet</span>
		    <span class="reddit"><i class="icon-reddit"></i> Submit</span>
		</div>

		

				

				
		<div style="margin: 50px auto" class="ad">
						<div class="subscribe clearfix">
	<div class="subscribe-cover">
		<p>Stay in the loop</p>
		<h3>GET A DAILY DIGEST OF LATEST TECHNOLOGY NEWS</h3>
		<p>Straight to your inbox</p>
	</div>
	<div class="subscribe-form">
		<p class="status">Subscribe to our newsletter</p>
		<form class="traqli" data-page="Single">
			<input type="email" id="sub_email" name="sub_email" placeholder="Enter your email" required /><input type="submit" value="Subscribe">
			<input type="hidden" name="action" value="submit_traqli">
		</form>		
	</div>
</div>

<link href="https://fonts.googleapis.com/css2?family=DM+Serif+Text&display=swap&text=GET%20A%20DAILY%20DIGEST%20OF%20LATEST%20TECHNOLOGY%20NEWS" rel="stylesheet">

<style>
.subscribe { border: 2px solid #EB0254; position: relative; margin: 125px 0; margin-left: -62px; margin-right: -62px; min-height: 100px }
.subscribe-cover { float:left; width:150px; background-color: #222; margin: -65px 0 -65px 35px; text-align: center; padding: 50px 15px; color: white; min-width: 290px; }
	.subscribe-cover img { margin-bottom: 20px }
	.subscribe-cover h3 { font-family: 'DM Serif Text', serif; margin-bottom: 15px; font-weight: normal; font-size: 30px }
	.subscribe-cover p { font-size: 12px;  color: #aaa; margin-bottom: 0; }
	.subscribe-cover p:first-child { margin-bottom: 15px; }

.subscribe-form  { padding: 40px; width: 100%; padding-left: 361px; }
	.subscribe-form p { font-weight: bold; margin-bottom: 15px; }
	.subscribe-form form { width: 100%; background: #eee; padding: 10px; border-radius: 10px }
	.subscribe-form form input { font-size: 14px; border:none; border-radius: 0; background-color: #eee }
	.subscribe-form form input:-webkit-autofill, .subscribe-form form input:focus:-webkit-autofill { -webkit-box-shadow: 0 0 0 100px rgb(238, 238, 238) inset; }
	.subscribe-form form input[type=email]  { width: 75%; padding: 10px; }
	.subscribe-form form input[type=submit] { width: 25%; padding: 10px 0; background: #EB0254; color: #fff; -webkit-appearance: none; border-radius: 25px }
	.subscribe-form form input[type=submit]:hover { background: #d2024b  }

@media only screen and (max-width: 1850px) {
	.subscribe {margin-left: -46px; margin-right: -46px;}
	.subscribe-cover { margin-left: 20px; }
	.subscribe-form { padding: 40px 23px; padding-left: 333px; }
}
</style>
		</div>

		<style>.subscribe { margin-top: 100px; }</style>
		
		
						
								
				<div class="related-posts widget-analytics clearfix" data-event="Related" data-page="Single" style="margin-top: 30px;">
					<h2 class="sub-head"><span>Related</span></h2>
					
	<div id='div-gpt-ad-1583497834297-0'></div>
		
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/doom-eternal-invasion-mode-cancelled-solo-horde-mode-replacement/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2020/01/WCCFdoometernal8-240x135.jpg" alt="wccfdoometernal8" srcset="https://cdn.wccftech.com/wp-content/uploads/2020/01/WCCFdoometernal8-480x270.jpg 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/doom-eternal-invasion-mode-cancelled-solo-horde-mode-replacement/">Doom Eternal’s Long-Promised Invasion Mode is Dead, Solo Horde Mode Coming Instead</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/nate/">Nathan Birch</a> &nbsp;•&nbsp; Jul 2					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1276720 http://wccftech.com/?p=1276720"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/doom-eternal-console-comparison-ray-tracing/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2018/08/DOOM_Eternal_6-240x135.jpg" alt="doom_eternal_6" srcset="https://cdn.wccftech.com/wp-content/uploads/2018/08/DOOM_Eternal_6-480x270.jpg 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/doom-eternal-console-comparison-ray-tracing/">DOOM Eternal New Console Comparison Videos Highlight Ray Tracing Features and More</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/francesco/">Francesco De Meo</a> &nbsp;•&nbsp; Jun 30					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1276050 http://wccftech.com/?p=1276050"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/the-elder-scrolls-vi-design-phase/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2018/07/The-Elder-Scrolls-VI-Engine-240x135.jpg" alt="the-elder-scrolls-vi-engine" srcset="https://cdn.wccftech.com/wp-content/uploads/2018/07/The-Elder-Scrolls-VI-Engine-480x270.jpg 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/the-elder-scrolls-vi-design-phase/">The Elder Scrolls VI Is Still in a Design Phase, Todd Howard Says</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/francesco/">Francesco De Meo</a> &nbsp;•&nbsp; Jun 29					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1275882 http://wccftech.com/?p=1275882"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/doom-eternal-xbox-series-xs-update-ps5/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2021/03/WCCFdoometernal12-240x135.jpg" alt="wccfdoometernal12" srcset="https://cdn.wccftech.com/wp-content/uploads/2021/03/WCCFdoometernal12-480x270.jpg 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/doom-eternal-xbox-series-xs-update-ps5/">[Updated: Out Now for XSX/PS5] Next-gen DOOM Eternal Xbox Series X|S Update is Being Rolled Out; PS5 Version Clocks in at 70GB</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/aernout/">Aernout van de Velde</a> &nbsp;•&nbsp; Jun 29					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1275810 http://wccftech.com/?p=1275810"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/id-softwares-project-2021b-has-been-rated-in-australia/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2021/03/WCCFdoometernal12-240x135.jpg" alt="wccfdoometernal12" srcset="https://cdn.wccftech.com/wp-content/uploads/2021/03/WCCFdoometernal12-480x270.jpg 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/id-softwares-project-2021b-has-been-rated-in-australia/">id Software&#8217;s Project 2021B Has Been Rated in Australia</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/francesco/">Francesco De Meo</a> &nbsp;•&nbsp; Jun 29					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1275801 http://wccftech.com/?p=1275801"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
					</div>

				
		
				<div id="disqus_thread"></div>
		<script>
			var disquspageurl = 'https://wccftech.com/new-doom-eternal-update-6-1/';
			var disqus_config = function () {
				this.page.url = disquspageurl;
				this.page.identifier = '1279204 http://wccftech.com/?p=1279204';
				this.callbacks.onNewComment = [function(comment) {
					if (typeof ga !== 'undefined') ga( 'send', 'event', 'Comments', 'Single', disquspageurl );
				}];
			};

			(function() {
				var d = document, s = d.createElement('script');
				s.src = '//wccftech.disqus.com/embed.js';
				s.setAttribute('data-timestamp', +new Date());
				(d.head || d.body).appendChild(s);
			})();
		</script>
		<noscript>Please enable JavaScript to view the comments.</noscript>
				

	</section>
    
        
	<aside class="sidebar">
		
	
		<div class="sidebar-ad">
			<div id='div-gpt-ad-1454066633851-2' style='height:250px; width:300px;'></div>
		</div>

		

		

	<section class="trending-posts sidebar-trending widget-analytics" data-event="Trending" data-page="Single">
		<h3 class="sub-head"><span>Trending Stories</span></h3>
		<ul><li><a href="https://wccftech.com/windows-terminal-preview-1-10-is-now-out-with-feature-improvements/">Windows Terminal Preview 1.10 Is Now Out with Some Nice Feature Improvements</a></li>
<li><a href="https://wccftech.com/a15-bionic-same-six-core-configuration-as-a14-bionic/">A15 Bionic Will Have the Same 6-Core CPU Configuration as the A14 Bionic</a></li>
<li><a href="https://wccftech.com/amd-raphael-zen4-based-cpus-rumored-to-only-have-16-cores/">AMD Raphael Zen4 Based CPUs Rumored To Only Have 16 Cores</a></li>
<li><a href="https://wccftech.com/intel-alder-lake-core-i9-12900k-qualification-sample-is-allegedly-able-to-achieve-a-turbo-of-5-3-ghz/">Intel &#8216;Alder Lake&#8217; Core i9-12900K Qualification Sample Is Allegedly Able To Achieve A Turbo Of 5.3 GHz</a></li>
<li><a href="https://wccftech.com/razer-unveils-the-blade-17-gaming-laptop-with-the-intel-core-i9-11900h-the-nvidia-geforce-rtx-3080/">Razer Unveils The Blade 17 Gaming Laptop With The Intel Core i9-11900H &#038; The NVIDIA GeForce RTX 3080</a></li>
</ul>	</section>

	
	
		<div class="sidebar-ad">
			<div id='div-gpt-ad-1454066633851-7' style='height:600px; width:300px;'></div>
		</div>

		
	<section class="popular-posts sidebar-popular widget-analytics" data-event="Popular" data-page="Single">
		<h3 class="sub-head"><span>Popular Discussions</span></h3>
		<ul><li class="popular-post-1"><a href="https://wccftech.com/amd-next-generation-threadripper-5000-series-chagall-launching-in-august/">AMD Next Generation Threadripper 5000 Series &#8220;Chagall&#8221; Launching In August</a><span>4999</span></li>
<li class="popular-post-2"><a href="https://wccftech.com/nvidia-geforce-rtx-3060-selling-for-270-usd-in-second-hand-markets-in-china-thanks-to-crypto-crackdown/">NVIDIA GeForce RTX 3060 Selling For 270 USD In Second Hand Markets In China Thanks To Crypto Crackdown</a><span>4346</span></li>
<li class="popular-post-3"><a href="https://wccftech.com/amd-raphael-zen4-based-cpus-rumored-to-only-have-16-cores/">AMD Raphael Zen4 Based CPUs Rumored To Only Have 16 Cores</a><span>3031</span></li>
<li class="popular-post-4"><a href="https://wccftech.com/intels-alder-lake-and-raptor-lake-pch-fillings-pop-on-sata-website/">Intel&#8217;s Alder Lake and Raptor Lake PCH Fillings Pop On SATA Website</a><span>2576</span></li>
<li class="popular-post-5"><a href="https://wccftech.com/intel-alder-lake-core-i9-12900k-qualification-sample-is-allegedly-able-to-achieve-a-turbo-of-5-3-ghz/">Intel &#8216;Alder Lake&#8217; Core i9-12900K Qualification Sample Is Allegedly Able To Achieve A Turbo Of 5.3 GHz</a><span>2290</span></li>
</ul>	</section>

	<section class="latest-posts sidebar-deals widget-analytics" data-event="Deals (Sidebar)" data-page="Single">
	<h3 class="sub-head"><span>Wccftech Store</span></h3>

<ul>
		
	<li class="clearfix first">
		<a href="https://wccftech.com/iscanner-app-lifetime-subscription-discount/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2021/07/iScanner-480x270.jpg"></div>
			<h4>iScanner App Lifetime Subscription Is Up For A Massive Offer This Week &#8211; Avail Now</h4>
		</a>
	</li>
	
		
	<li class="clearfix ">
		<a href="https://wccftech.com/2021-premium-ethical-hacking-certification-bundle-discount/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2021/07/2021-Premium-Ethical-Hacking-Certification-Bundle-86x60.jpg"></div>
			<h4>2021 Premium Ethical Hacking Certification Bundle Is Up For An Amazing Discount Offer For A Few Hours &#8211; Avail Now</h4>
		</a>
	</li>
	
		
	<li class="clearfix ">
		<a href="https://wccftech.com/travelhacker-premium-subscription-discount/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2021/07/TravelHacker-Premium-Subscription-86x60.jpg"></div>
			<h4>TravelHacker Premium Subscription Is Up For An Amazing Discount Offer For A Few Hours &#8211; Avail Now</h4>
		</a>
	</li>
	
		
	<li class="clearfix ">
		<a href="https://wccftech.com/learn-productivity-personal-development-bundle-discount/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2021/07/2021-Learn-Productivity-Personal-Development-Bundle-86x60.jpg"></div>
			<h4>Learn Productivity &#038; Personal Development Bundle Is Up For An Amazing Discount Offer &#8211; Avail Now</h4>
		</a>
	</li>
	
		
	<li class="clearfix ">
		<a href="https://wccftech.com/javascript-dom-game-developer-bundle-discount/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2021/07/JavaScript-DOM-Game-Developer-Bundle-86x60.jpg"></div>
			<h4>JavaScript DOM Game Developer Bundle Is Up For An Amazing Discount Offer &#8211; Avail Now</h4>
		</a>
	</li>
	
	</ul>	</section>

	
	<!-- TAGNAME: 300x600_sidebar_bot -->
	<!-- /8095840/.2_A.38567.7_wccftech.com_tier1 -->
	<div id='div-gpt-ad-wccftechcom38567'></div>

</aside><!-- end aside class sidebar -->
    </div><!-- end clearfix -->

</main>

<footer data-nosnippet>

    <section class="wrap clearfix">
				
				
		<div class="footer-1">
			<!--<i class="fa fa-folder-open-o"></i>-->
			<h3>Sections</h3>
			<ul>
				<li><a href="/review/">Reviews</a></li>
				<li><a href="/videos/">Videos</a></li>
				<li><a href="/how-to/">How To's</a></li>
				<li><a href="/topic/exclusive/">Exclusives</a></li>
				<li><a href="/topic/interview/">Interviews</a></li>
				<li><a href="/topic/deals/">Deals</a></li>
				<li><a href="/topic/entertainment/">Entertainment</a></li>
				<li><a href="/pc-builder/">PC Builder</a></li>
			</ul>
		</div>
		
		<div class="footer-2">
			<!--<i class="fa fa-hashtag"></i>-->
			<h3>Topics</h3>
			<ul>
				<li><a href="/topic/hardware/">Hardware</a></li>
				<li><a href="/topic/games/">Gaming</a></li>
				<li><a href="/topic/gadgets/">Mobile</a></li>
				<li><a href="/topic/finance/">Finance</a></li>
				<li><a href="/topic/software/">Software</a></li>
				<li><a href="/topic/security/">Security</a></li>
				<li><a href="/topic/web/">Web</a></li>
			</ul>
		</div>
		
		<div class="footer-3">
			<!--<i class="fa fa-info"></i>-->
			<h3>Know Us</h3>
			<ul>
				<li><a href="/about/">About</a></li>
				<li><a href="/advertise/">Advertise</a></li>
				<li><a href="/contact/">Contact</a></li>
				<li><a href="/tip-us/">Tip Us</a></li>
				<li><a href="/jobs/">Careers</a></li>
				<li><a href="/legal-disclaimer/">Terms of Use</a></li>
				<li><a href="/privacy-policy/">Privacy &amp; Cookie Policy</a></li>
				<li><a href="/ethics-statement/">Ethics Statement</a></li>
				<li><a href="/moderation/">Appeal Moderation</a></li>
				<li>
					<script>
					(function waitGEO() {
					    var readyGEO;
					    if (window['UnicI'] && window['UnicI'].geo && window['UnicI'].geo !== '-' ) {
					        readyGEO = true;
					        console.log(window['UnicI'].geo);
					        if (window['UnicI'].geo === 'EU') {
					            if(document.getElementById("unic-gdpr")) {
					              document.getElementById("unic-gdpr").style.display = 'block';
					            }
					        }
					        if (window['UnicI'].geo === 'CA') {
					            if(document.getElementById("unic-ccpa")) {
					              document.getElementById("unic-ccpa").style.display = 'block';
					            }
					        }
					    }
					    if (!readyGEO) {
					        setTimeout(waitGEO, 200);
					    }
					})();
					</script>
					<a id='unic-gdpr' onclick='__tcfapi("openunic");return false;' style='display:none;cursor:pointer;'>Change Ad Consent</a>
					<a id='unic-ccpa' onclick="window.__uspapi('openunic')" style='display:none;cursor:pointer;'>Do not sell my data</a>
				</li>
			</ul>
		</div>

		<div class="footer-4">
			<!--<i class="fa"></i>-->
			<h3>Follow US</h3>
			<ul>
				<li class="twitter"><a href="https://twitter.com/wccftech"><i class="icon-twitter"></i> Twitter</a></li>
				<li class="facebook"><a href="https://www.facebook.com/wccftech"><i class="icon-facebook"></i> Facebook</a></li>
				<li class="youtube"><a href="https://www.youtube.com/wccftechtv"><i class="icon-youtube"></i> YouTube</a></li>
			</ul><br><br>

			<div>
				<h3 style="margin-bottom: 10px;">Subscribe</h3>
				<p class="status">For latest tech news in your inbox, once a day!</p>
				<form class="traqli" data-page="Single">
					<input type="email" id="sub_email" name="sub_email" placeholder="Email address" required /><input type="submit" value="Subscribe">
					<input type="hidden" name="action" value="submit_traqli">
				</form>
			</div>
		</div>

		<div class="copyright">
			<span class="logo"><a href="https://wccftech.com/" rel="home">Wccftech</a></span>
			<span class="text">
				&copy; 2021 WCCF TECH INC. All rights reserved.
			</span>
			<span class="preload-images"></span>
		</div>

		<div class="disclaimer">Some posts on Wccftech.com may contain affiliate links. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to Amazon.com</div>

		
    </section>
</footer>

<script type="text/javascript">var algolia = {"debug":false,"application_id":"JP6Z5G2P43","search_api_key":"4784f5ddc534ec220ede8a86867f33c7","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"searchable_posts","index_name":"wp_searchable_posts","label":"All posts","admin_name":"All posts","position":10,"max_suggestions":5,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"wp_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]}}};</script><script type='text/javascript' src='https://cdn.wccftech.com/wp-content/themes/wccf2016/script.js?ver=1625257245' id='wccf-script-js'></script>
<script type='text/javascript' src='https://cdn.wccftech.com/wp-content/themes/wccf2016/footer.js?ver=1625257245' id='wccf-footer-js'></script>

<script type="text/javascript" src="https://s.skimresources.com/js/31026X886738.skimlinks.js"></script>
<div id="amzn-assoc-ad-54373194-91c7-4e61-b9a0-12cad6711106"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=54373194-91c7-4e61-b9a0-12cad6711106"></script>

<!-- /8095840/.2_12459.46_wccftech.com_tier1 -->
<div id='div-gpt-ad-1559306343883-0' style='height:1px; width:1px;'>
<script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1559306343883-0'); });</script>
</div>

<script id="dsq-count-scr" src="//wccftech.disqus.com/count.js" async></script>

<script type="text/javascript">
;!function(){
    window.PianoESPConfig = {
        id: 301
    }
    var e=document.createElement("script");e.setAttribute("id","pnesplucidsdksel"),e.type="text/javascript",e.src="//api-esp.piano.io/public/sdk/v04/sdk.js?v="+(localStorage&&localStorage.lucidsdkver||"xxx"),e.async=!0,document.getElementsByTagName("script")[0].parentNode.appendChild(e);
}();
</script>


<style>
	.mpp-toc-container { max-width: 100%; padding: 0; width: 100%; border: none; margin: 0; }
	.mpp-toc-title h2 { text-align: left; margin-top: 0; margin-bottom: 0; color: white; }
	.mpp-toc-title { padding: 10px 15px; background: #EB0254; color: white; }
	.mpp-toc { padding: 15px; background: white; border: 1px solid #EB0254; }
	.mpp-toc-container ul li { margin-bottom: 5px; }
	.mpp-page-link { display: inline; float: right; }
	.mpp-page-link a { color: white }
	nav.mpp-post-navigation .nav-links a { font-size: 80%; text-transform: uppercase; padding: 5px 0; width: auto; }
	nav.mpp-post-navigation .nav-links a:hover { border: none; text-decoration: underline; }
	nav.mpp-post-navigation .nav-links a[rel="next"]:after { content: '\00bb'; padding-left: 10px; }
	nav.mpp-post-navigation .nav-links a[rel="previous"]:before { content: '\00ab'; padding-right: 10px; }
</style>

<script src="//dsh7ky7308k4b.cloudfront.net/autoads/wccftechcom-single.min.js"></script>

<style>
.qc-cmp-persistent-link {display: none !important;}
</style>
</body>
</html>
