<!DOCTYPE html>
<html lang="en-US">
<head>

<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=no">
<meta property="fb:app_id" content="58923144965" />
<meta property="fb:pages" content="71411645007" />
<meta name="author" content="Nathan Birch" />
<link rel="shortcut icon" type='image/x-icon' href="https://wccftech.com/favicon.ico" />
<link rel="apple-touch-icon" sizes="180x180" href="https://wccftech.com/icons/apple-touch-icon.png">
<link rel="icon" type="image/png" href="https://wccftech.com/icons/favicon-32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="https://wccftech.com/icons/favicon-16x16.png" sizes="16x16">
<link rel="manifest" href="https://wccftech.com/icons/manifest.json">
<link rel="mask-icon" href="https://wccftech.com/icons/safari-pinned-tab.svg" color="#5bbad5">
<meta name="apple-mobile-web-app-title" content="Wccftech">
<meta name="application-name" content="Wccftech">
<meta name="theme-color" content="#ffffff">

<style>@import url('https://fonts.googleapis.com/css?family=Fira+Sans:400,500|Open+Sans:400,700');</style>



	<!-- This site is optimized with the Yoast SEO Premium plugin v15.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Cyberpunk 2077’s DLC Won’t Be Detailed Until After the Game’s Release</title>
	<meta name="description" content="Cyberpunk 2077 will have at least as much DLC as The Witcher 3, but we won&#039;t be hearing about it before launch." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://wccftech.com/cyberpunk-2077-dlc-reveal-not-until-after-release/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Cyberpunk 2077’s DLC Won’t Be Detailed Until After the Game’s Release" />
	<meta property="og:description" content="Cyberpunk 2077 will have at least as much DLC as The Witcher 3, but we won&#039;t be hearing about it before launch." />
	<meta property="og:url" content="https://wccftech.com/cyberpunk-2077-dlc-reveal-not-until-after-release/" />
	<meta property="og:site_name" content="Wccftech" />
	<meta property="article:publisher" content="https://www.facebook.com/wccftech" />
	<meta property="article:published_time" content="2020-11-26T23:37:11+00:00" />
	<meta property="og:image" content="https://cdn.wccftech.com/wp-content/uploads/2019/06/WCCFcyberpunk207711.jpg" />
	<meta property="og:image:width" content="740" />
	<meta property="og:image:height" content="429" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@wccftech" />
	<meta name="twitter:site" content="@wccftech" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Nathan Birch">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="1 minute">
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Wccftech &raquo; Feed" href="https://wccftech.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Wccftech &raquo; Comments Feed" href="https://wccftech.com/comments/feed/" />
<link rel='stylesheet' id='wccf-main-css'  href='https://cdn.wccftech.com/wp-content/themes/wccf2016/style.css?ver=1606124856' type='text/css' media='all' />
<link rel='stylesheet' id='wccf-style-single-css'  href='https://cdn.wccftech.com/wp-content/themes/wccf2016/style-single.css?ver=1606222615' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://wccftech.com/wp-json/" /><link rel="alternate" type="application/json" href="https://wccftech.com/wp-json/wp/v2/posts/1226999" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://wccftech.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cdn.wccftech.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='https://wccftech.com/?p=1226999' />
<link rel="alternate" type="application/json+oembed" href="https://wccftech.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwccftech.com%2Fcyberpunk-2077-dlc-reveal-not-until-after-release%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://wccftech.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwccftech.com%2Fcyberpunk-2077-dlc-reveal-not-until-after-release%2F&#038;format=xml" />
<script type='text/javascript'>
	(function () {
		var pl_beacon = document.createElement('script');
		pl_beacon.type = 'text/javascript';
		pl_beacon.async = true;
		var host = 'https://wccftech.com';
		if ('https:' == document.location.protocol) {
			host = host.replace('http://', 'https://');
		}
		pl_beacon.src = host + '/' + 'cnt7vfDVvWa3' + '.js?ts=' + Math.floor((Math.random() * 100000) + 1);
		var first_script_tag = document.getElementsByTagName('script')[0];
		first_script_tag.parentNode.insertBefore(pl_beacon, first_script_tag);
	})();
</script>		<style>
			.algolia-search-highlight {
				background-color: #fffbcc;
				border-radius: 2px;
				font-style: normal;
			}
		</style>
		<link rel="amphtml" href="https://wccftech.com/cyberpunk-2077-dlc-reveal-not-until-after-release/amp/">

<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
	
	ga('create', 'UA-3244067-1', 'auto');
	  ga('set', 'dimension1', 'Nathan Birch');
  ga('set', 'dimension2', 'News,Sticky');
  ga('set', 'dimension3', '1606415831');
  ga('set', 'dimension4', 'post');
  ga('set', 'dimension8', 'Gaming,Gaming (AAA)');
	ga('send', 'pageview');
</script>

<style>
	@font-face {font-family: 'icomoon';  src: url('//cdn.wccftech.com/fonts/icomoon10.eot'); src: url('//cdn.wccftech.com/fonts/icomoon10.eot#iefix') format('embedded-opentype'), url('//cdn.wccftech.com/fonts/icomoon10.ttf') format('truetype'), url('//cdn.wccftech.com/fonts/fonts/icomoon10.woff') format('woff'), url('//cdn.wccftech.com/fonts/icomoon10.svg#icomoon') format('svg'); font-weight: normal; font-style: normal; }
</style>



<script>var mypage = 'news';
var mytopic = 'games';
</script>


	
		<script src="https://cmp.uniconsent.com/v2/stub.min.js"></script>
		<script async src='https://cmp.uniconsent.com/v2/4d73da7830/cmp.js'></script>
		<script type="text/javascript">
		window.googletag = window.googletag || {};
		window.googletag.cmd = window.googletag.cmd || [];
		window.googletag.cmd.push(function () {
		    window.googletag.pubads().enableAsyncRendering();
		    window.googletag.pubads().disableInitialLoad();
		});
		(adsbygoogle = window.adsbygoogle || []).pauseAdRequests = 1;
		</script>
		<script>
		__tcfapi("addEventListener", 2, function(tcData, success) {
		    if (success && tcData.unicLoad  === true) {
		        if(!window._initAds) {
					window._initAds = true;

					var script = document.createElement('script');
					script.src = 'https://z.moatads.com/pubgalaxyheader468736715877/moatheader.js';
					document.head.appendChild(script);

					var script = document.createElement('script');
					script.async = true;
					script.src = 'https://d3lyxljmb9awzt.cloudfront.net/publishers/wccftechcom_new.min.js';
					document.head.appendChild(script);

					var script = document.createElement('script');
					script.async = true;
					script.src = 'https://pubgalaxy-com.videoplayerhub.com/gallery.js';
					document.head.appendChild(script);

		        }
		    }
		});
		</script>

		<script src="https://cdn.nsstatic.com/ns/wccftech.com.js" id="nsgpt" async="true"></script>

	


<!--[if lt IE 9]>
    <script src="//cdn.wccftech.com/files/html5shiv.min.js"></script>
<![endif]-->


	<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	<script type="text/javascript" src="https://native.sharethrough.com/assets/sfp.js"></script>



<meta name="twitter:image" content="https://cdn.wccftech.com/wp-content/uploads/2019/06/WCCFcyberpunk207711.jpg">
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://wccftech.com/cyberpunk-2077-dlc-reveal-not-until-after-release/"
  },
  "headline": "Cyberpunk 2077’s DLC Won’t Be Detailed Until After the Game’s Release",
  "image": [
    "https://cdn.wccftech.com/wp-content/uploads/2019/06/WCCFcyberpunk207711.jpg"
   ],
  "datePublished": "2020-11-26T23:37:11+00:00",
  "dateModified": "2020-11-26T23:37:11+00:00",
  "author": {
    "@type": "Person",
    "name": "Nathan Birch"
  },
   "publisher": {
    "@type": "Organization",
    "name": "Wccftech",
    "url": "https://wccftech.com/",
    "logo": {
      "@type": "ImageObject",
      "url": "https://cdn.wccftech.com/wp-content/uploads/images/wccftech-logo.png"
    }
  },
  "description": "Cyberpunk 2077 is going to be a big game, the kind you play for 170 hours without beating, but CD Projekt Red is also promising a large amount of DLC. At least as much as The Witcher 3 had. Back in September, CDPR CEO Adam Kiciński hinted they would reveal DLC details prior to the [&amp;hellip;]"
}
</script>




</head>

<body class="post-template-default single single-post postid-1226999 single-format-standard">

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1503230403325633');
fbq('track', 'PageView');
</script><noscript><img height="1" width="1" alt="" style="display:none" src="https://www.facebook.com/tr?id=1503230403325633&ev=PageView&noscript=1"/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->

<header>
	<section class="wrap clearfix">
		<a href="https://wccftech.com/"  rel="home"><div class="logo">Wccftech</div></a>

		<ul class="nav widget-analytics" data-event="Menu" data-page="Single">
			<li><a href="/category/news/"   title="See all news">News</a></li>
			<li><a href="/topic/hardware/"  title="See all hardware news">Hardware</a></li>
			<li><a href="/topic/games/"     title="See all gaming news">Gaming</a></li>
			<li><a href="/topic/gadgets/"   title="See all mobile news">Mobile</a></li>
			<li><a href="/topic/finance/"   title="See all finance news">Finance</a></li>
			<li><a href="/topic/deals/"     title="See all our deals posts">Deals</a></li>
			<li><a href="/review/"          title="See all reviews">Reviews</a></li>
			<!--<li><a href="/topic/exclusive/"  title="See all our exclusive stories">Exclusives</a></li>-->
			<!--<li><a href="/pc-builder/"      title="PC Builder by Wccftech">PC Builder</a></li>-->
		</ul>
		<div class="toggle-search" title="Search"></div>
	</section>
	<div class="search-form">
		<form class="wrap" action="/find/"><input id="q" name="q" type="text" placeholder="What do you want to search for?" autocomplete="off"><input type="submit"></form>
	</div>
</header>

<div class="banner-ad" style="margin: 0 auto 40px auto;">
	<div id='div-gpt-ad-1454066633851-0' style="min-height:90px" class="position-ads"></div>	
</div>
		<div class="main-background-wrap"><div class="main-background"></div></div>
	
<main class="wrap clearfix" style="">	

	<div class="clearfix">
	
    <section class="content">
	    		
		<div class="topics"><a href="https://wccftech.com/topic/games/" rel="tag">Gaming</a>&nbsp; &#8942; &nbsp;<a href="https://wccftech.com/topic/aaa-gaming/" rel="tag">Gaming (AAA)</a></div>
	
		<h1 class="page-heading">Cyberpunk 2077’s DLC Won’t Be Detailed Until After the Game’s Release</h1>
			
	    <div class="single-meta">
		    <div class="meta-left">
				<div class="meta-author">By <a href="https://wccftech.com/author/nate/" title="Posts by Nathan Birch" rel="author">Nathan Birch</a></div>
			    <div class="meta-time">
					<time datetime="2020-11-26T23:37:11+00:00" title="Nov 26, 2020 18:37 EST">
						Nov 26, 2020 18:37 EST					</time>
														</div>
		    </div>
		    <div class="meta-share meta-share-top">
			    			    <span class="facebook"><i class="icon-facebook"></i> Share</span><span class="twitter"><i class="icon-twitter"></i> Tweet</span><span class="reddit"><i class="icon-reddit"></i> Submit</span>
			</div>
	    </div>
		
		<div class="body clearfix">
		
			<div class="wp-caption aligncenter featured-image"><div class="wp-lightbox"><a href="https://cdn.wccftech.com/wp-content/uploads/2019/06/WCCFcyberpunk207711.jpg"><img width="740" height="429" src="https://cdn.wccftech.com/wp-content/uploads/2019/06/WCCFcyberpunk207711-740x429.jpg" class="attachment-large size-large wp-post-image" alt="Cyberpunk 2077" loading="lazy" srcset="https://cdn.wccftech.com/wp-content/uploads/2019/06/WCCFcyberpunk207711.jpg 740w, https://cdn.wccftech.com/wp-content/uploads/2019/06/WCCFcyberpunk207711-410x238.jpg 410w" sizes="(max-width: 740px) 100vw, 740px" /></a></div></div>
			<p><a href="https://wccftech.com/tag/cyberpunk-2077/" target="_blank" rel="noopener noreferrer">Cyberpunk 2077</a> is going to be a big game, the kind you <a href="https://wccftech.com/cyberpunk-2077-170-hours-gameplay/" target="_blank" rel="noopener noreferrer">play for 170 hours without beating</a>, but CD Projekt Red is also promising a large amount of DLC. <a href="https://wccftech.com/cyberpunk-2077-as-much-dlc-as-witcher-3-more-info-soon/" target="_blank" rel="noopener noreferrer">At least as much as The Witcher 3 had</a>. Back in September, CDPR CEO Adam Kiciński hinted they would <a href="https://wccftech.com/cyberpunk-2077-to-have-more-dlc-than-the-witcher-3-setting-is-great-to-sell-things-in-multiplayer/" target="_blank" rel="noopener noreferrer">reveal DLC details prior to the launch of Cyberpunk 2077</a>.</p>
<blockquote><p>Yes, you can expect a similar path after release. You can expect more, actually. We’re not going into too many details today, but everything will be clear before release. As we are close to the release, expect the post-release plans to be revealed fairly soon. A series of free DLCs and expansions will be described – as I said, you can expect it fairly soon and then everything will be made clear.</p></blockquote>
<p>Well, Cyberpunk 2077 has suffered a couple delays since then, and now it seems CDPR isn’t ready to talk about post-launch plans until after release. This was revealed by Kiciński during CDPR’s most recent earnings call (tip of the hat to <a href="https://www.videogameschronicle.com/news/cd-projekt-red-has-delayed-cyberpunk-2077s-dlc-reveal-until-after-release/" target="_blank" rel="noopener noreferrer">Video Games Chronicle for taking note of the quote</a>)…</p>
<p id="" class="wccf_related_post"><a class="wccf_related_post" href="https://wccftech.com/cyberpunk-2077-bugs-multiplayer/"> Cyberpunk 2077 Bugs Will Be Hard to Spot; Multiplayer May Be Discussed in the First Quarter of 2021</a></p><div id="" class="wccf_video_tag"><div id="div-gpt-ad-1586516229806-0"></div></div><blockquote><p>The initial plan was to do it before release, but after the recent delay, we decided to wait for the release to provide gamers with the game and then start talking about future projects. So, after release.</p></blockquote>
<p>So, when might we learn about Cyberpunk 2077’s DLC? Well, <a href="https://wccftech.com/cyberpunk-2077-bugs-multiplayer/" target="_blank" rel="noopener noreferrer">as we previously reported</a>, CDPR will be talking about Cyberpunk 2077 multiplayer in the first quarter of 2021, so it seems likely we learn about other post-launch plans at around the same time.</p>
<blockquote><p>I said already we are not focusing right now on talking too much about other future products, products that are to be released after Cyberpunk. So please be with us in the first quarter of next year when we plan to share some strategy update. And I believe Cyberpunk multiplayer will be possible.</p></blockquote>
<p>Cyberpunk 2077 launches on PC, Xbox One, and PS4 on December 10, and can be played on Xbox Series X/S and PS5 via backward compatibility. Full next-gen upgrades are coming in early 2021.</p>			
						
		</div>

				
		<div class="wccf-products"><h4><span>Products mentioned in this post</span></h4><a target="_blank" rel="nofollow sponsored" class="wccf-product wccf-product-300442" href="https://amzn.to/37LtQCQ" data-code="B07DJWBYKP" data-product="Cyberpunk 2077"><span><img alt="Cyberpunk 2077" src="https://images-na.ssl-images-amazon.com/images/I/81iR0aGNJ5L._SL1500_.jpg" width="60" height="60"></span><div>Cyberpunk 2077<br><small>USD 49.94</small></div></a> <p class="amazon-disclosure">The links above are affiliate links. As an Amazon Associate, Wccftech.com may earn from qualifying purchases.</p></div>
	    <div class="meta-share meta-share-bottom clearfix">
		    <span class="facebook"><i class="icon-facebook"></i> Share</span>
		    <span class="twitter"><i class="icon-twitter"></i> Tweet</span>
		    <span class="reddit"><i class="icon-reddit"></i> Submit</span>
		</div>

		

				

				
		<div style="margin: 50px auto" class="ad">
						<div><a href="https://tidd.ly/3fDxlNC" rel="sponsored"><img src="https://cdn.wccftech.com/wp-content/uploads/2020/11/asfhndd3341.jpg" style="width:100%; height: auto;"></a></div>
		</div>

		<style>.subscribe { margin-top: 100px; }</style>
		
		
						
								
				<div class="related-posts widget-analytics clearfix" data-event="Related" data-page="Single" style="margin-top: 30px;">
					<h2 class="sub-head"><span>Related</span></h2>
					
	<div id='div-gpt-ad-1583497834297-0'></div>
		
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/cyberpunk-2077-ps5-ps4-pro-gameplay-day-1-patch/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2020/06/WCCFcyberpunk207715-240x135.jpg" alt="wccfcyberpunk207715" srcset="https://cdn.wccftech.com/wp-content/uploads/2020/06/WCCFcyberpunk207715-480x270.jpg 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/cyberpunk-2077-ps5-ps4-pro-gameplay-day-1-patch/">Cyberpunk 2077 Shows Off PS5 and PS4 Pro Gameplay, Day 1 Patch Reconfirmed</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/nate/">Nathan Birch</a> &nbsp;•&nbsp; Nov 24					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1225746 http://wccftech.com/?p=1225746"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/cyberpunk-2077-170-hours-gameplay/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2020/08/Cyberpunk2077_Shopping_RGB_EN-240x135.jpg" alt="cyberpunk2077_shopping_rgb_en" srcset="https://cdn.wccftech.com/wp-content/uploads/2020/08/Cyberpunk2077_Shopping_RGB_EN-480x270.jpg 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/cyberpunk-2077-170-hours-gameplay/">Cyberpunk 2077 Will Reportedly Offer 170+ Hours of Gameplay</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/brittany/">Brittany Vincent</a> &nbsp;•&nbsp; Nov 23					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1225441 http://wccftech.com/?p=1225441"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/cyberpunk-2077-trailer-21-million-views/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2020/07/Cyberpunk-2077-240x135.jpg" alt="cyberpunk-2077-12" srcset="https://cdn.wccftech.com/wp-content/uploads/2020/07/Cyberpunk-2077-480x270.jpg 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/cyberpunk-2077-trailer-21-million-views/">Cyberpunk 2077 Latest Gameplay Trailer Surpasses 21 Million Views in Just a Few Days</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/francesco/">Francesco De Meo</a> &nbsp;•&nbsp; Nov 23					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1225325 http://wccftech.com/?p=1225325"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/cyberpunk-2077-ray-tracing-not-available-on-amd-radeon-at-launch/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2020/11/cyberpunk_2077_rtx_reflections-240x135.jpg" alt="cyberpunk_2077_rtx_reflections" srcset="https://cdn.wccftech.com/wp-content/uploads/2020/11/cyberpunk_2077_rtx_reflections-480x270.jpg 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/cyberpunk-2077-ray-tracing-not-available-on-amd-radeon-at-launch/">Cyberpunk 2077 Ray Tracing Not Available on AMD Radeon at Launch</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/alessio/">Alessio Palumbo</a> &nbsp;•&nbsp; Nov 21					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1225136 http://wccftech.com/?p=1225136"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
			
		<article class="post clearfix">
			<div class="thumb" style="background-image:url('//cdn.wccftech.com/wp-content/uploads/images/post-thumb.png')">
				<a href="https://wccftech.com/cyberpunk-2077-updated-system-requirements/"><img width="240" height="135" src="https://cdn.wccftech.com/wp-content/uploads/2020/11/Cyberpunk-Updated-System-Requirements-01-Header-240x135.jpg" alt="cyberpunk-updated-system-requirements-01-header" srcset="https://cdn.wccftech.com/wp-content/uploads/2020/11/Cyberpunk-Updated-System-Requirements-01-Header-480x270.jpg 2x" /></a>
			</div>
			<div class="text">
				<h3><a href="https://wccftech.com/cyberpunk-2077-updated-system-requirements/">Cyberpunk 2077 Updated System Requirements, Ray Tracing Setups Also Listed</a></h3>
				<div class="meta">
					<a href="https://wccftech.com/author/chriswray/">Chris Wray</a> &nbsp;•&nbsp; Nov 20					<div class="float-right">
						<span class="disqus-comment-count" data-disqus-identifier="1225025 http://wccftech.com/?p=1225025"></span> &nbsp;&nbsp;
						<i class="icon-share"></i> 10					</div>		
				</div>
			</div>
		</article>
					</div>

				
		
				<div id="disqus_thread"></div>
		<script>
			var disquspageurl = 'https://wccftech.com/cyberpunk-2077-dlc-reveal-not-until-after-release/';
			var disqus_config = function () {
				this.page.url = disquspageurl;
				this.page.identifier = '1226999 http://wccftech.com/?p=1226999';
				this.callbacks.onNewComment = [function(comment) {
					if (typeof ga !== 'undefined') ga( 'send', 'event', 'Comments', 'Single', disquspageurl );
				}];
			};

			(function() {
				var d = document, s = d.createElement('script');
				s.src = '//wccftech.disqus.com/embed.js';
				s.setAttribute('data-timestamp', +new Date());
				(d.head || d.body).appendChild(s);
			})();
		</script>
		<noscript>Please enable JavaScript to view the comments.</noscript>
				

	</section>
    
        
	<aside class="sidebar">
		
	
		<div class="sidebar-ad">
			<div id='div-gpt-ad-1454066633851-2' style='height:250px; width:300px;'></div>
		</div>

		

		

	<section class="trending-posts sidebar-trending widget-analytics" data-event="Trending" data-page="Single">
		<h3 class="sub-head"><span>Trending Stories</span></h3>
		<ul><li><a href="https://wccftech.com/amd-ryzen-5000-cpu-smart-access-memory-support-for-x470-b450-motherboards/">AMD Ryzen 5000 CPU &#038; Smart Access Memory Support For X470 &#038; B450 Motherboards Only Via Unofficial BIOS, New AGESA Firmware in January</a></li>
<li><a href="https://wccftech.com/evga-zotac-custom-geforce-rtx-3060-ti-graphics-cards-leak-ftw-xc3-twin-edge/">EVGA &#038; ZOTAC Custom GeForce RTX 3060 Ti Graphics Cards Leak Out &#8211; FTW, XC3, Twin Edge</a></li>
<li><a href="https://wccftech.com/nvidia-geforce-rtx-3060-ti-benchmarks-leak-3dmark-geekbench-mining-performance/">NVIDIA GeForce RTX 3060 Ti 3DMark Benchmarks Leak Out &#8211; 10% Slower Than The RTX 3070 For Around $399 US, Mining Performance Detailed</a></li>
<li><a href="https://wccftech.com/watch-dogs-legion-playstation-5-xbox-series-x/">Watch Dogs Legion Runs Identical Visual Settings On PlayStation 5, Xbox Series X</a></li>
<li><a href="https://wccftech.com/cyberpunk-2077-ps4-xo-performance-surprisingly-good/">Cyberpunk 2077 PS4/XO Performance is “Surprisingly Good” Given the Game’s Huge World, CDPR Says</a></li>
</ul>	</section>

	
	
		<div class="sidebar-ad">
			<div id='div-gpt-ad-1454066633851-7' style='height:600px; width:300px;'></div>
		</div>

		
	<section class="popular-posts sidebar-popular widget-analytics" data-event="Popular" data-page="Single">
		<h3 class="sub-head"><span>Popular Discussions</span></h3>
		<ul><li class="popular-post-1"><a href="https://wccftech.com/nvidia-rtx-3060-ti-graphics-card-poised-to-be-the-budget-king-at-399-msrp-and-faster-than-rtx-2080-super-performance/">NVIDIA RTX 3060 Ti Graphics Card Poised To Be The Budget King At $399 MSRP And Faster Than RTX 2080 SUPER Performance</a><span>4507</span></li>
<li class="popular-post-2"><a href="https://wccftech.com/powercolor-radeon-rx-6800-xt-red-devil-overclocked-2-65-ghz-on-air/">PowerColor Radeon RX 6800 XT Red Devil Overclocked &#038; Tested &#8211; 2.65 GHz on Air, Scores Over 56,000 Points In 3DMark Fire Strike</a><span>3956</span></li>
<li class="popular-post-3"><a href="https://wccftech.com/cyberpunk-2077-ray-tracing-not-available-on-amd-radeon-at-launch/">Cyberpunk 2077 Ray Tracing Not Available on AMD Radeon at Launch</a><span>3727</span></li>
<li class="popular-post-4"><a href="https://wccftech.com/amd-radeon-rx-6800-xt-rx-6800-custom-model-roundup-asus-msi-gigabyte-powercolor-sapphire-xfx-asrock/">AMD Radeon RX 6800 XT &#038; RX 6800 Custom Model Roundup Ft. ASUS, MSI, Gigabyte, PowerColor, Sapphire, XFX, ASRock &#038; More</a><span>3340</span></li>
<li class="popular-post-5"><a href="https://wccftech.com/more-radeon-rx-6700-series-details-emerge-for-a-midrange-powerhouse/">More Radeon RX 6700 Series Details Emerge For A Midrange Powerhouse</a><span>2517</span></li>
</ul>	</section>

	<section class="latest-posts sidebar-deals widget-analytics" data-event="Deals (Sidebar)" data-page="Single">
	<h3 class="sub-head"><span>Wccftech Store</span></h3>

<ul>
		
	<li class="clearfix first">
		<a href="https://wccftech.com/complete-web-developer-coding-bundle-limited/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2020/11/Complete-Web-Developer-Coding-Bundle-480x270.jpg"></div>
			<h4>Complete Web Developer Coding Bundle Is Up For A Massive Discount Offer For A Few Days &#8211; Avail Now</h4>
		</a>
	</li>
	
		
	<li class="clearfix ">
		<a href="https://wccftech.com/machine-learning-for-beginners-overview-bundle-limited/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2020/11/Machine-Learning-for-Beginners-Overview-Bundle-86x60.jpg"></div>
			<h4>Machine Learning for Beginners Overview Bundle Can Be Yours For Under $20 If You Avail It In The Next 3 Days</h4>
		</a>
	</li>
	
		
	<li class="clearfix ">
		<a href="https://wccftech.com/12min-micro-book-library-lifetime-limited/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2020/11/12min-Micro-Book-Library-Lifetime-Premium-Subscription-86x60.jpg"></div>
			<h4>12min Micro Book Library Lifetime Premium Subscription Is Up For A Massive Discount For A Few Hours &#8211; Avail Now</h4>
		</a>
	</li>
	
		
	<li class="clearfix ">
		<a href="https://wccftech.com/python-for-everyone-course-discount-limited/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2020/11/Python-for-Everyone-Course-86x60.jpg"></div>
			<h4>Python for Everyone Course Is Up For A 92% Discount Offer For The Next Three Days &#8211; Avail Now</h4>
		</a>
	</li>
	
		
	<li class="clearfix ">
		<a href="https://wccftech.com/salesforce-administrator-certification-bundle-limited/" class="clearfix">
			<div class="thumb"><img src="https://cdn.wccftech.com/wp-content/uploads/2020/11/Salesforce-Administrator-Certification-Bundle-86x60.jpg"></div>
			<h4>Salesforce Administrator Certification Bundle Is Up For A Limited Time Discount Offer &#8211; Avail Now</h4>
		</a>
	</li>
	
	</ul>	</section>

	
</aside><!-- end aside class sidebar -->
    </div><!-- end clearfix -->

</main>

<footer data-nosnippet>

    <section class="wrap clearfix">
				
				
		<div class="footer-1">
			<!--<i class="fa fa-folder-open-o"></i>-->
			<h3>Sections</h3>
			<ul>
				<li><a href="/review/">Reviews</a></li>
				<li><a href="/how-to/">How To's</a></li>
				<li><a href="/topic/exclusive/">Exclusives</a></li>
				<li><a href="/topic/interview/">Interviews</a></li>
				<li><a href="/topic/deals/">Deals</a></li>
				<li><a href="/topic/video/">Video</a></li>
				<li><a href="/topic/entertainment/">Entertainment</a></li>
				<li><a href="/pc-builder/">PC Builder</a></li>
			</ul>
		</div>
		
		<div class="footer-2">
			<!--<i class="fa fa-hashtag"></i>-->
			<h3>Topics</h3>
			<ul>
				<li><a href="/topic/hardware/">Hardware</a></li>
				<li><a href="/topic/games/">Gaming</a></li>
				<li><a href="/topic/gadgets/">Mobile</a></li>
				<li><a href="/topic/finance/">Finance</a></li>
				<li><a href="/topic/software/">Software</a></li>
				<li><a href="/topic/security/">Security</a></li>
				<li><a href="/topic/web/">Web</a></li>
			</ul>
		</div>
		
		<div class="footer-3">
			<!--<i class="fa fa-info"></i>-->
			<h3>Know Us</h3>
			<ul>
				<li><a href="/about/">About</a></li>
				<li><a href="/advertise/">Advertise</a></li>
				<li><a href="/contact/">Contact</a></li>
				<li><a href="/tip-us/">Tip Us</a></li>
				<li><a href="/jobs/">Careers</a></li>
				<li><a href="/legal-disclaimer/">Terms of Use</a></li>
				<li><a href="/privacy-policy/">Privacy &amp; Cookie Policy</a></li>
				<li><a href="/ethics-statement/">Ethics Statement</a></li>
				<li>
					<script>
					(function waitGEO() {
					    var readyGEO;
					    if (window['UnicI'] && window['UnicI'].geo && window['UnicI'].geo !== '-' ) {
					        readyGEO = true;
					        console.log(window['UnicI'].geo);
					        if (window['UnicI'].geo === 'EU') {
					            if(document.getElementById("unic-gdpr")) {
					              document.getElementById("unic-gdpr").style.display = 'block';
					            }
					        }
					        if (window['UnicI'].geo === 'CA') {
					            if(document.getElementById("unic-ccpa")) {
					              document.getElementById("unic-ccpa").style.display = 'block';
					            }
					        }
					    }
					    if (!readyGEO) {
					        setTimeout(waitGEO, 200);
					    }
					})();
					</script>
					<a id='unic-gdpr' onclick='__tcfapi("openunic");return false;' style='display:none;cursor:pointer;'>Change Ad Consent</a>
					<a id='unic-ccpa' onclick="window.__uspapi('openunic')" style='display:none;cursor:pointer;'>Do not sell my data</a>
				</li>
			</ul>
		</div>

		<div class="footer-4">
			<!--<i class="fa"></i>-->
			<h3>Follow US</h3>
			<ul>
				<li class="twitter"><a href="https://twitter.com/wccftech"><i class="icon-twitter"></i> Twitter</a></li>
				<li class="facebook"><a href="https://www.facebook.com/wccftech"><i class="icon-facebook"></i> Facebook</a></li>
				<li class="youtube"><a href="https://www.youtube.com/wccftechtv"><i class="icon-youtube"></i> YouTube</a></li>
			</ul><br><br>

			<div>
				<h3 style="margin-bottom: 10px;">Subscribe</h3>
				<p class="status">For latest tech news in your inbox, once a day!</p>
				<form class="traqli" data-page="Single">
					<input type="email" id="sub_email" name="sub_email" placeholder="Email address" required /><input type="submit" value="Subscribe">
					<input type="hidden" name="action" value="submit_traqli">
				</form>
			</div>
		</div>

		<div class="copyright">
			<span class="logo"><a href="https://wccftech.com/" rel="home">Wccftech</a></span>
			<span class="text">
				&copy; 2020 NewAge ADS, LLC. All rights reserved.
			</span>
			<span class="preload-images"></span>
		</div>

		<div class="disclaimer">Some posts on Wccftech.com may contain affiliate links. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to Amazon.com</div>

    </section>
</footer>

<script type="text/javascript">var algolia = {"debug":false,"application_id":"JP6Z5G2P43","search_api_key":"4784f5ddc534ec220ede8a86867f33c7","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"searchable_posts","index_name":"wp_searchable_posts","label":"All posts","admin_name":"All posts","position":10,"max_suggestions":5,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"wp_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]}}};</script><script type='text/javascript' src='https://cdn.wccftech.com/wp-content/themes/wccf2016/script.js?ver=1605967495' id='wccf-script-js'></script>
<script type='text/javascript' src='https://cdn.wccftech.com/wp-content/themes/wccf2016/footer.js?ver=1605967495' id='wccf-footer-js'></script>

<script type="text/javascript" src="https://s.skimresources.com/js/31026X886738.skimlinks.js"></script>
<div id="amzn-assoc-ad-54373194-91c7-4e61-b9a0-12cad6711106"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=54373194-91c7-4e61-b9a0-12cad6711106"></script>

<!-- /8095840/.2_12459.46_wccftech.com_tier1 -->
<div id='div-gpt-ad-1559306343883-0' style='height:1px; width:1px;'>
<script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1559306343883-0'); });</script>
</div>

<script id="dsq-count-scr" src="//wccftech.disqus.com/count.js" async></script>

<script type="text/javascript">
;!function(){
    window.NewzmateConfig = {
        id: 83
    }
    var e=document.createElement("script");e.setAttribute("id","tqlucidsdksel"),e.type="text/javascript",e.src="//api.traq.li/public/sdk/v04/sdk.js?v="+(localStorage&&localStorage.lucidsdkver||"xxx"),e.async=!0,document.getElementsByTagName("script")[0].parentNode.appendChild(e);
}();
</script>


<style>
	.mpp-toc-container { max-width: 100%; padding: 0; width: 100%; border: none; margin: 0; }
	.mpp-toc-title h2 { text-align: left; margin-top: 0; margin-bottom: 0; color: white; }
	.mpp-toc-title { padding: 10px 15px; background: #EB0254; color: white; }
	.mpp-toc { padding: 15px; background: white; border: 1px solid #EB0254; }
	.mpp-toc-container ul li { margin-bottom: 5px; }
	.mpp-page-link { display: inline; float: right; }
	.mpp-page-link a { color: white }
	nav.mpp-post-navigation .nav-links a { font-size: 80%; text-transform: uppercase; padding: 5px 0; width: auto; }
	nav.mpp-post-navigation .nav-links a:hover { border: none; text-decoration: underline; }
	nav.mpp-post-navigation .nav-links a[rel="next"]:after { content: '\00bb'; padding-left: 10px; }
	nav.mpp-post-navigation .nav-links a[rel="previous"]:before { content: '\00ab'; padding-right: 10px; }
</style>

<script src="//dsh7ky7308k4b.cloudfront.net/autoads/wccftechcom-single.min.js"></script>

<style>
.qc-cmp-persistent-link {display: none !important;}
</style>
</body>
</html>

	<style>
		@media only screen and (max-width: 6000px) {
			.main-background-wrap { position: relative; }
			.main-background { background: url(https://cdn.wccftech.com/wp-content/uploads/2020/11/wccf-banner-1440p.jpg) center top no-repeat; cursor: pointer; position: absolute; top:0; left: 0; width: 100%; height: 2160px}
		}

		@media only screen and (max-width: 2300px) {
			.main-background-wrap { position: relative; }
			.main-background { background: url(https://cdn.wccftech.com/wp-content/uploads/2020/11/Wccf-banner-1080p.jpg) center top no-repeat; cursor: pointer; position: absolute; top:0; left: 0; width: 100%; height: 900px }		
		}

		@media only screen and (max-width: 1850px) {
			.main-background-wrap { position: relative; }
			.main-background { background: url(https://cdn.wccftech.com/wp-content/uploads/2020/11/wccf-banner-1080p-thin.jpg) center top no-repeat; cursor: pointer; position: absolute; top:0; left: 0; width: 100%; height: 900px }
		}

		@media only screen and (max-width: 1440px) {
			.main-background-wrap { position: relative; }
			.main-background { background: url(https://cdn.wccftech.com/wp-content/uploads/2020/11/768p.jpg) center top no-repeat; cursor: pointer; position: absolute; top:0; left: 0; width: 100%; height: 768px }
		}
	</style>
	<script>
	(function($) {
	$(document).ready(function() {

	$(".main-background").click(function(e){

		if(e.target == this) {

			var midpoint = $(this).innerWidth() / 2;

			if( midpoint > e.pageX ) {
				window.open("https://tidd.ly/2JdSXUI")
			} else {
				window.open("https://tidd.ly/2JdSXUI");
			}

		}

	});

	});
	})(jQuery);
	</script>


